Bug 962077 - File conflict in installing ZoneMinder
File conflict in installing ZoneMinder
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: meataxe (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 10:29 EDT by Germano Massullo
Modified: 2013-05-31 23:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: meataxe-2.4.24-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 00:30:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2013-05-11 10:29:13 EDT
Description of problem:
When installing ZoneMinder package from yum, I obtain the following error message:
file /usr/bin/zmu from install of zoneminder-1.25.0-11.fc18.x86_64 conflicts with file from package meataxe-2.4.24-3.fc18.x86_64
Comment 1 Jason Tibbitts 2013-05-20 11:35:28 EDT
Can't really help this; zoneminder was in the distro way before this meataxe package came in.  And it seems to want a bunch of three-letter binary names starting with 'z'.  This should have been caught in the meataxe review, but it wasn't.
Comment 2 Jason Tibbitts 2013-05-20 11:41:39 EDT
So, meataxe folks, your package appears to want a whole bunch of three letter binary names starting with 'z', including /usr/bin/zmc which is part of the zoneminder package.  I have no idea why this wasn't caught during your package review, because zoneminder has been in the distro since 2007.

We'll need to figure out how to deal with this conflict somehow; I may be able to rename within zoneminder but it would take a good bit of patching and potentially breaking of end-user configurations.  Zoneminder also has selinux policy which may need adjusting for that kind of thing.
Comment 3 Jerry James 2013-05-20 11:49:21 EDT
Uh oh.  Sorry about that.  So far as I know, meataxe is only used by gap.  Probably the best thing to do is use environment-modules to hide the meataxe binaries from view, then patch gap to adapt.  I'll try to get that done in the next day or two.
Comment 4 Fedora Update System 2013-05-21 13:47:36 EDT
meataxe-2.4.24-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/meataxe-2.4.24-5.fc19
Comment 5 Fedora Update System 2013-05-21 13:47:47 EDT
meataxe-2.4.24-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/meataxe-2.4.24-5.fc18
Comment 6 Fedora Update System 2013-05-22 18:39:54 EDT
Package meataxe-2.4.24-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing meataxe-2.4.24-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8875/meataxe-2.4.24-5.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-05-31 00:30:46 EDT
meataxe-2.4.24-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-05-31 23:20:02 EDT
meataxe-2.4.24-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.