Bug 96208 - (NPB3750) removal of phone columns from contact_methods table
removal of phone columns from contact_methods table
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Jones
Karen Jacqmin-Adams
:
Depends On:
Blocks: 120995
  Show dependency treegraph
 
Reported: 2002-05-09 15:41 EDT by Nick Hansen
Modified: 2007-10-23 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 14:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Hansen 2002-05-09 15:41:32 EDT
Given that phone contact methods are permanently deprecated, we should remove
the following columns from the contact_methods table:

 PHONE_AREA_CODE
 PHONE_NUMBER 
 PHONE_EXTENSION
Comment 1 Nick Hansen 2003-06-06 08:18:44 EDT
This is a bug that has been migrated over from the old NOCpulse Bugzilla. The original NP bugid was 3750, the original reporter was Alyssa Umsawasdi, and the original assigned to was Greg Peters.
Comment 2 Nick Hansen 2003-06-26 12:55:54 EDT
I'll take this as work to do, if there are no objections from others that this
happen.
Comment 3 Karen Jacqmin-Adams 2004-05-28 11:00:37 EDT
I dropped the phone columns as part of monitoring schema migration.

#  How was this issue addressed?
Dropped these columns from rhn_contact_method in initial definition:
 PHONE_AREA_CODE
 PHONE_NUMBER 
 PHONE_EXTENSION

# What level of users are affected? 
None.

# Where specifically can the change be seen?
Database schema only

# If the change cannot be verified visually, how should it be tested?
1) sqlplus command: "desc rhn_contact_methods" should not be able
to find the specified phone columns after the monitoring schema is
deployed
2) monitoring schema should deploy rhn_contact_methods cleanly

Transfering bug to Peter to mark as ON_DEV when the monitoring schema
is deployed to webdev.
Comment 4 Peter Jones 2004-05-31 17:57:05 EDT
on dev.
Comment 5 Nick Hansen 2004-06-02 16:25:13 EDT
nope, the specified columns are not present in the rhn_contact_methods
table in either webdev or wedqa. Looks good.
Comment 6 Matt Jamison 2004-06-21 10:02:58 EDT
need to test on sat.

moving back to on_qa and upgrading priority to high since it's a
schema change and needs a fine tooth comb.
Comment 7 Fanny Augustin 2004-07-02 18:05:27 EDT
This is mainly a database schema change so I do not think it will 
affect satellite build one way or the other.  I have been working 
with the sats all week long and I have not observed any anomallies.  

Note You need to log in before you can comment on or make changes to this bug.