Bug 962088 - fence_sanlock (2.6-2.el6) agent script incompatible with pacemaker 1.1.8-7.el6
fence_sanlock (2.6-2.el6) agent script incompatible with pacemaker 1.1.8-7.el6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sanlock (Show other bugs)
7.0
Unspecified Linux
unspecified Severity unspecified
: rc
: 7.1
Assigned To: David Teigland
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 13:02 EDT by John McCabe
Modified: 2016-05-31 10:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-13 12:17:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John McCabe 2013-05-11 13:02:03 EDT
Description of problem:
Currently unable to use fence_sanlock as an agent with pacemaker (1.1.8), RH fencing agent api not fully implemented (monitor, list etc)

Version-Release number of selected component (if applicable):
fence-sanlock-2.6-2.el6.x86_64

How reproducible:
Can be reproduced by attempting to use fence_sanlock as a stonith agent in pacemaker.

Steps to Reproduce:
1. CMAN running and using the pacemaker redirect fencing agent.

2. Pacemaker running (pacemaker-1.1.8-7.el6.x86_64), attempt to add a stonith device using the fence_sanlock agent (note that the host list, map and custom argument were included since fence_sanlock does not use the host name)
pcs stonith create st-sanlock fence_sanlock path="/dev/mapper/vg_shared-lv_sanlock" pcmk_host_list="hostname1 hostname2" pcmk_host_map="hostname1:1;hostname2:2" pcmk_host_argument="host_id

3. Check status of stonith device using pcs status and monitor logs
  
Actual results:
Device will be added to the running cib, but will fail as the monitor operation is not supported, from /var/log/messages;

May 10 01:33:42 hostname1 stonith-ng[10542]:  warning: log_operation: st-sanlock:10725 [ host_id argument required ]

Expected results:
Expectation had been that the provided fence_sanlock agent would be compatible with pacemaker.

Additional info:
I'd raised this on the pacemaker mailing list to see if anyone had previously used fence_sanlock with pacemaker, and whether it was intended to be used as such. I was requested to raise a ticket here.

Wasn't sure whether to raise this against the sanlock or fence-agents component, chose sanlock since its listed as the srpm for the fence-agent package

Thanks,
John
Comment 1 John McCabe 2013-05-11 13:03:58 EDT
Adding Andrew to cc list as requested
Comment 3 Andrew Beekhof 2013-05-12 20:11:07 EDT
There are at least two deviations from:
   https://fedorahosted.org/cluster/wiki/FenceAgentAPI 

- agents need to support the monitor action
- targets are to be specified with either port or nodename
Comment 4 David Teigland 2013-05-13 11:49:53 EDT
I've moved this to RHEL7; RHEL6 is tech preview and if it is moved to supported it would be with some very limited validated usages, which would not include pacemaker.

Broader support would have to be considered for RHEL7. fence_sanlock is a bit peculiar, it isn't quite like other simplistic fence agents; I'm not sure how all the details would work in a pacemaker environment.  We may have to add some new
restrictions/checks/caveats/etc.

As far as "monitor" goes, it's one of those things that may not make sense here.
As far as the agent args, I believe the agent currently specifies that in its
"metadata" output.
Comment 6 Andrew Beekhof 2013-05-29 22:49:12 EDT
Either its a fencing agent or its not.
If it is, then it needs to conform to the published API.
Comment 10 David Teigland 2015-04-13 12:17:18 EDT
Not planning any more work on fence_sanlock.
Comment 11 Jan Pokorný 2016-05-31 08:14:35 EDT
David, in that case, please consider dropping fence-sanlock subpackage
from distribution as no package is better than not well-integrated one.
Comment 12 Jan Pokorný 2016-05-31 08:16:49 EDT
(or at least, making it not discovered by pacemaker)
Comment 13 David Teigland 2016-05-31 10:26:06 EDT
I suspect dropping a package is not so simple, but I'll try and see what happens.

Note You need to log in before you can comment on or make changes to this bug.