Bug 962098 - AttributeError: 'NoneType' object has no attribute 'split'
AttributeError: 'NoneType' object has no attribute 'split'
Status: CLOSED DUPLICATE of bug 959710
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e589c402a8288468842f5ff695f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 14:40 EDT by A.J. Werkman
Modified: 2013-05-20 20:20 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 20:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (528.46 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: anaconda.log (6.51 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: backtrace (897 bytes, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: environ (826 bytes, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: ifcfg.log (485 bytes, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: lsblk_output (1.45 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.29 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: packaging.log (179.40 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: program.log (25.95 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: storage.log (66.05 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details
File: syslog (103.94 KB, text/plain)
2013-05-11 14:40 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2013-05-11 14:40:07 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
AttributeError: 'NoneType' object has no attribute 'split'

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   nomodeset ip=212.115.199.60::212.115.199.57:255.255.255.248:testsys.digifarma.nl::none noipv6 nameserver=212.115.199.57 inst.stage2=hd:UUID=45658a8b-656a-4895-a8a8-fe99b5d3a962
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
AttributeError: 'NoneType' object has no attribute 'split'
Comment 1 A.J. Werkman 2013-05-11 14:40:12 EDT
Created attachment 746621 [details]
File: anaconda-tb
Comment 2 A.J. Werkman 2013-05-11 14:40:16 EDT
Created attachment 746622 [details]
File: anaconda.log
Comment 3 A.J. Werkman 2013-05-11 14:40:18 EDT
Created attachment 746623 [details]
File: backtrace
Comment 4 A.J. Werkman 2013-05-11 14:40:20 EDT
Created attachment 746624 [details]
File: environ
Comment 5 A.J. Werkman 2013-05-11 14:40:22 EDT
Created attachment 746625 [details]
File: ifcfg.log
Comment 6 A.J. Werkman 2013-05-11 14:40:24 EDT
Created attachment 746626 [details]
File: lsblk_output
Comment 7 A.J. Werkman 2013-05-11 14:40:26 EDT
Created attachment 746627 [details]
File: nmcli_dev_list
Comment 8 A.J. Werkman 2013-05-11 14:40:30 EDT
Created attachment 746628 [details]
File: packaging.log
Comment 9 A.J. Werkman 2013-05-11 14:40:34 EDT
Created attachment 746629 [details]
File: program.log
Comment 10 A.J. Werkman 2013-05-11 14:40:36 EDT
Created attachment 746630 [details]
File: storage.log
Comment 11 A.J. Werkman 2013-05-11 14:40:39 EDT
Created attachment 746631 [details]
File: syslog
Comment 12 Reartes Guillermo 2013-05-13 10:40:04 EDT
Description of problem:
I booted netinst with boot parameter "askmethod" to test bug 889887 and confirm Adam's comment.

I can select the installation source.
I choose nfs, and it was configured ok.

Software selection was in "nothing selected".
As soon as i enter Software Selection, nothing could be done (except moving the mouse) until anaconda crashed.

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet askmethod BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
AttributeError: 'NoneType' object has no attribute 'split'
Comment 13 Reartes Guillermo 2013-05-13 11:11:52 EDT
With the askmethod boot parameter (used to workaround the need for wait for closest mirror to finish to switch to other installation sources when using netinst) after selecting the installation source (nfs, ftp, -others untested-) anaconda crashes when entering software selection.
Comment 14 Reartes Guillermo 2013-05-13 11:29:56 EDT
FROM: https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Package_sets

> When doing a graphical install using the dedicated installer 
> images, the installer must be able to install each of the 
> release blocking desktops, as well as the minimal package set.

Since anaconda crashes after entering the spoke, nothing can be installed.

Context:

* Using NETINST, not the regular iso.

* Using the boot parameter 'askmethod' (see Bug 889887)
This is used to avoid having to wait for closest mirror to finish if one wants to use ftp, nfs, etc. (on slow connections or bad behaved connection/situations this can be a big inconvenience).

* The crash happens right after entering Software Selection, one cannot select any Base Environment.
  

Workaround:

* Do not boot with 'askmethod' boot parameter. (and thus, Bug 889887 becomes relevant again, even if   a bootparamer exists, it cannot be used).

* Wait for closest mirror to finish before switching to the desired/needed installation source. As explained in Bug 889887, waiting can be very inconvenient, connection might be slow, leading to log wait times +20', network problems, mirrors being slow at that moment +30'. For example, while i can download an iso at 1000kb approx, sometimes i see yum update using only 10kb!
Comment 15 Adam Williamson 2013-05-13 12:44:22 EDT
Discussed at 2013-05-13 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-13/f19beta-blocker-review-5.2013-05-13-16.00.log.txt . Rejected as a blocker: we doubt many will be using the 'askmethod' parameter, and the issue isn't a showstopper as you _can_ live without it and suffer the wait. So this doesn't need to block the Beta release.
Comment 16 Reartes Guillermo 2013-05-13 13:14:59 EDT
Update: Reproduced without 'askmethod' boot parameter

* boot without kernel parameter the netinstall iso
* when closest mirror is being setup, go to network and disable the network. (off)
* wait some time, then you can select a new software source
* enter network and re-enable the network
* change the installation source, ftp, nfs
* the new installation source is setup
* enter software selection, crash.
Comment 17 Adam Williamson 2013-05-20 20:20:14 EDT

*** This bug has been marked as a duplicate of bug 959710 ***

Note You need to log in before you can comment on or make changes to this bug.