Bug 962113 - Disable libguestfs block drivers which are not supported by RHEL 7 qemu + libvirt
Disable libguestfs block drivers which are not supported by RHEL 7 qemu + lib...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 17:33 EDT by Richard W.M. Jones
Modified: 2014-06-17 21:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.22.5-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:09:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-05-11 17:33:27 EDT
Description of problem:

Upstream libguestfs now supports many of upstream qemu's block
drivers.  Currently that list is:

file
ftp
ftps
gluster
http
https
iscsi
nbd
rbd
sheepdog
ssh
tftp

Some of these will not be supported in qemu.  Some are not
supported by libvirt (not even upstream libvirt).

We need to find out which will be supported in qemu + libvirt
in RHEL 7, and limit the devices to just those.  The others would
be removed from the documentation (and implementation?) in
libguestfs in RHEL 7.

Version-Release number of selected component (if applicable):

libguestfs in RHEL 7

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=875871
enable nbd block driver [component = qemu-kvm]

There is no general bug or documentation I can find about
what qemu will eventually support.  But that information can
be found in the spec file.

My current understanding is this:

            qemu       |   libvirt
         upst.| RHEL7  |  upst.| RHEL7
file       Y      Y         Y      Y
ftp        Y      N         N      N
ftps       Y      N         N      N
gluster    Y                Y
http       Y      N         N      N
https      Y      N         N      N
iscsi      Y                [1]
nbd        Y   bug 875871   Y
rbd        Y                Y
sheepdog   Y                Y
ssh        Y                [2]
tftp       Y      N         N      N

[1] = Supposed to be supported, but I couldn't get it to work.
[2] = Patch posted upstream, but needs further work.
Comment 2 Richard W.M. Jones 2013-06-04 07:31:09 EDT
Dan can you help to fill in the table (comment 0)?
Comment 3 Daniel Berrange 2013-06-04 07:37:01 EDT
I don't believe we've made any decisions about the block device support list for RHEL-7 yet in libvirt or kvm.
Comment 4 Richard W.M. Jones 2013-07-11 05:54:24 EDT
ssh support seems unlikely before at least RHEL 7.1.  The reasons
are this needs further work in qemu & libvirt:

qemu: Support for more authentication types.

libvirt: Fix the ssh driver and get it upstream and test it
with libguestfs.

libguestfs: Some (minor) changes may be needed to make the
libvirt backend fully functional with ssh.
Comment 5 Richard W.M. Jones 2013-07-29 10:44:18 EDT
This RHEL-7-only commit was added:

https://github.com/libguestfs/libguestfs/commit/690381015f09cb5ceef9de939771b81f30429eb4
Comment 7 bfan 2013-12-02 00:08:05 EST
Verified with libguestfs-1.22.6-16.el7.x86_64

1. test nbd driver
qemu-nbd -v -t RHEL-Server-6.4-64-hvm.raw &
virt-inspector -a nbd://10.66.84.13


2. test file driver
virt-inspector -a file:///path/RHEL-Server-6.4-64-hvm.raw


All works well, so change the status to verified
Comment 8 Ludek Smid 2014-06-13 07:09:59 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.