Bug 962142 - AIO setup fails if rpcbind is already enabled.
AIO setup fails if rpcbind is already enabled.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.2
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Alex Lourie
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 20:12 EDT by Stephen Gordon
Modified: 2013-07-22 07:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 07:04:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-05-11 20:12:57 EDT
Description of problem:

It appears that if the rpcbind service (or other services for that matter, more on that in a second) is already enabled on an F18 system then the AIO install fails. The reason being that "chkconfig rpcbind on" redirects to systemctl with returns an error code becaus ethe link is already present?

2013-05-11 17:48:17::DEBUG::common_utils::473::root:: stderr = 
2013-05-11 17:48:17::DEBUG::common_utils::474::root:: retcode = 0
2013-05-11 17:48:17::DEBUG::common_utils::434::root:: Executing command --> '/sbin/chkconfig rpcbind on'
2013-05-11 17:48:17::DEBUG::common_utils::472::root:: output = 
2013-05-11 17:48:17::DEBUG::common_utils::473::root:: stderr = Note: Forwarding request to 'systemctl enable rpcbind.service'.
Failed to issue method call: File exists

2013-05-11 17:48:17::DEBUG::common_utils::474::root:: retcode = 1
2013-05-11 17:48:17::ERROR::engine-setup::1849::root:: Traceback (most recent call last):
  File "/bin/engine-setup", line 1845, in _startNfsServices
    service.autoStart(True)
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 1252, in autoStart
    execCmd(cmdList=cmd, failOnError=True)
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 477, in execCmd
    raise Exception(msg)
Exception: Return Code is not zero

2013-05-11 17:48:17::ERROR::engine-setup::1770::root:: Traceback (most recent call last):
  File "/bin/engine-setup", line 1756, in _configNfsShare
    _startNfsServices()
  File "/bin/engine-setup", line 1850, in _startNfsServices
    raise Exception(output_messages.ERR_FAILED_TO_START_NFS_SERVICE)
Exception: Failed to start the NFS services

2013-05-11 17:48:17::DEBUG::setup_sequences::62::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/setup_sequences.py", line 60, in run
    function()
  File "/bin/engine-setup", line 1771, in _configNfsShare
    raise Exception(output_messages.ERR_FAILED_CFG_NFS_SHARE)
Exception: Failed to configure NFS share on this host

===

If I disable rpcbind and re-run I just get an error on the next service:

===

2013-05-11 20:09:35::DEBUG::common_utils::473::root:: stderr = 
2013-05-11 20:09:35::DEBUG::common_utils::474::root:: retcode = 0
2013-05-11 20:09:35::DEBUG::common_utils::434::root:: Executing command --> '/sbin/chkconfig sshd on'
2013-05-11 20:09:35::DEBUG::common_utils::472::root:: output = 
2013-05-11 20:09:35::DEBUG::common_utils::473::root:: stderr = Note: Forwarding request to 'systemctl enable sshd.service'.
Failed to issue method call: File exists

2013-05-11 20:09:35::DEBUG::common_utils::474::root:: retcode = 1
2013-05-11 20:09:35::ERROR::all_in_one_100::294::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/plugins/all_in_one_100.py", line 284, in createHost
    sshd.autoStart()
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 1252, in autoStart
    execCmd(cmdList=cmd, failOnError=True)
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 477, in execCmd
    raise Exception(msg)
Exception: Return Code is not zero

2013-05-11 20:09:35::DEBUG::setup_sequences::62::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/setup_sequences.py", line 60, in run
    function()
  File "/usr/share/ovirt-engine/scripts/plugins/all_in_one_100.py", line 295, in createHost
    raise Exception(ERROR_CREATE_LOCAL_HOST)
Exception: Error: Could not install local host

Versions:

ovirt-engine-setup-3.2.1-1.fc18.noarch
ovirt-engine-setup-plugin-allinone-3.2.1-1.fc18.noarch
Comment 1 Alex Lourie 2013-06-27 08:04:54 EDT
@Stephen

First, this is not really a problem with AIO - it happens earlier than AIO code starts to run.

Second, I just ran the master 3.3 setup with both legacy (engine-setup) and otopi-based (engine-setup-2) utilities, and it worked fine with rpcbind running prior to that. Hence, I suspect that the issue is not rpcbind related.

Could you please cleanup the system with engine-cleanup, and try running again? Please attach full logs of the setup when it's done.

Thank you.
Comment 2 Stephen Gordon 2013-07-09 18:07:31 EDT
(In reply to Alex Lourie from comment #1)
> @Stephen
> 
> First, this is not really a problem with AIO - it happens earlier than AIO
> code starts to run.
> 
> Second, I just ran the master 3.3 setup with both legacy (engine-setup) and
> otopi-based (engine-setup-2) utilities, and it worked fine with rpcbind
> running prior to that. Hence, I suspect that the issue is not rpcbind
> related.

As per bug description I was specifically trying oVirt stable (3.2.1) on Fedora 18.

> Could you please cleanup the system with engine-cleanup, and try running
> again? Please attach full logs of the setup when it's done.

I no longer have the relevant system available, given the install was broken and the lack of response here I removed it.

Note You need to log in before you can comment on or make changes to this bug.