This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 962187 - vm down because of client reset. assert error
vm down because of client reset. assert error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.4
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks: 1227410
  Show dependency treegraph
 
Reported: 2013-05-12 08:02 EDT by bigclouds
Modified: 2015-06-02 11:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: spice-server-0.12.4-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
: 1227410 (view as bug list)
Environment:
Last Closed: 2014-10-14 01:04:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest vm log (37.43 KB, text/plain)
2013-05-12 08:02 EDT, bigclouds
no flags Details

  None (edit)
Description bigclouds 2013-05-12 08:02:29 EDT
Created attachment 746858 [details]
guest vm log

Description of problem:


Version-Release number of selected component (if applicable):
spice-server 0.10.*.rpm

How reproducible:
unplug cable, wait minutes(on purpose, sure server aware and clean infos of client) , plug cable again. repeat that process again and again(There is a probability).


Steps to Reproduce:
1.
2.
3.
  
Actual results:
guest vm assert.

Expected results:
guest should work as normal 

Additional info:
i am not familar with the code, but i suggest  there is a way  on which each thread conmunicaate with each other
Comment 2 Yonit Halperin 2013-06-28 11:41:42 EDT
The spice-server rpm is old (rhel-6.3). Is this bug reproducible over Rhel6.4? If it is reproducible, can you please attach the qemu log file, running with the highest spice debug level (export SPICE_DEBUG_LEVEL=5, before executing qemu).
Comment 3 RHEL Product and Program Management 2013-10-13 23:35:35 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Christophe Fergeau 2014-04-09 06:12:12 EDT
Can you still reproduce this?
Comment 5 Marc-Andre Lureau 2014-06-25 08:37:42 EDT
snd_receive: ASSERT n failed

It looks like a misbehaving client could easily reach that condition by sending too big messages.

Instead of assert() we could replace with a warning. When a too big message is received, it would simply disconnect the channel.

sent patch:
http://lists.freedesktop.org/archives/spice-devel/2014-June/017015.html
Comment 6 Marc-Andre Lureau 2014-06-25 08:49:08 EDT
Hmm, from the log it seems you managed to get
snd_channel_put: sound channel freed

without a previous "snd_disconnect_channel: .."

so the channel structure could also point to garbage.
Comment 11 errata-xmlrpc 2014-10-14 01:04:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1435.html
Comment 12 David Jaša 2015-01-07 09:39:44 EST
Removing needinfo on closed bugs.

Note You need to log in before you can comment on or make changes to this bug.