Bug 962208 - OT Can't install Spacewalk; jpackage.org not accessible
OT Can't install Spacewalk; jpackage.org not accessible
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.9
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2013-05-12 10:59 EDT by tommylovell
Modified: 2017-09-28 14:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 05:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tommylovell 2013-05-12 10:59:18 EDT
Description of problem:
Can't install Spacewalk 1.9 on Fedora 17.  jpackage.org repository does not seem to be available.

Version-Release number of selected component (if applicable):
Spacewalk 1.9
Fedora 17

How reproducible:
Every time.

Steps to Reproduce:
1. Follow steps in https://fedorahosted.org/spacewalk/wiki/HowToInstall
2. Add jpackage repository with

   cat > /etc/yum.repos.d/jpackage-generic.repo << EOF
   [jpackage-generic]
   name=JPackage generic    #baseurl=http://mirrors.dotsrc.org/pub/jpackage/5.0/generic/free/
   mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0
   enabled=1
   gpgcheck=1
   gpgkey=http://www.jpackage.org/jpackage.asc
   EOF

3. yum install spacewalk-setup-embedded-postgresql

      Loaded plugins: langpacks, presto, refresh-packagekit
   Could not retrieve mirrorlist http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0 error was
   14: curl#6 - "Could not resolve host: www.jpackage.org; Name or service not known"
   spacewalk                                                                     | 2.1 kB     00:00     
   updates/17/x86_64/metalink                                                    |  17 kB     00:00     
   updates                                                                       | 4.4 kB     00:00     
   be46f9da28afca00a3d95164f43a2a FAILED curl#22 - "The requested URL returned error: 404 Not Found"
   http://mirrors.usc.edu/pub/linux/distributions/fedora/linux/updates/17/x86_64/repodata/be46f9da28afca00a3d95164f43a2a2d3ee1e38b6d9a17fcf0808a2ca8524eb1-primary.sqlite.bz2: [Errno 14] curl#22 - "The requested URL returned error: 404 Not Found"
   Trying other mirror.
   updates/primary_db                                                            | 8.1 MB     00:04     
   Package spacewalk-setup-embedded-postgresql-1.9.1-1.fc17.noarch already installed and latest version
   Nothing to do

4. yum install spacewalk-postgresql gets

...
   Downloading Packages:
   warning: rpmts_HdrFromFdno: Header V3 DSA/SHA1 Signature, key ID c431416d: NOKEY
   Retrieving key from http://www.jpackage.org/jpackage.asc


   GPG key retrieval failed: [Errno 14] curl#6 - "Could not resolve host: www.jpackage.org; Name or service not known"
  
Actual results:
Can't complete installation

Expected results:
Completed installation

Additional info:
I understand this is probably off topic as it is really a jpackage repository issue, but as there doesn't seem to be a way to contact anyone associated with jpackage.org, and Spacewalk is dependent on jpackage, I'm opening this problem here (and hoping that someone can help).

If you Google www.jpackage.org and look at the repository, it says the following, and you can see what was on that page as of Apr 3:
This is Google's cache of http://www.jpackage.org/. It is a snapshot of the page as it appeared on Apr 3, 2013 18:23:35 GMT.

My repositories:
[root@athlonz yum.repos.d]# yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
repo id                                   repo name                                            status
fedora/17/x86_64                          Fedora 17 - x86_64                                   27,033
jpackage-generic                          JPackage generic                                      3,307
spacewalk/x86_64                          Spacewalk                                               139
updates/17/x86_64                         Fedora 17 - x86_64 - Updates                         12,629
repolist: 43,108

Thanks.
Comment 1 tommylovell 2013-05-12 11:03:31 EDT
2. above really looks like this:

[root@athlonz yum.repos.d]# cat jpackage-generic.repo 
[jpackage-generic]
name=JPackage generic
#baseurl=http://mirrors.dotsrc.org/pub/jpackage/5.0/generic/free/
mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0
enabled=1
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc

The formatting in the submission is a little off.

I also tried:

[root@athlonz yum.repos.d]# cat jpackage-generic.repo 
[jpackage-generic]
name=JPackage generic
baseurl=http://mirrors.dotsrc.org/pub/jpackage/5.0/generic/free/
#mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0
enabled=1
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc

Same results.
Comment 2 Jan Pazdziora 2013-05-13 04:58:53 EDT
(In reply to comment #0)
> I understand this is probably off topic as it is really a jpackage
> repository issue, but as there doesn't seem to be a way to contact anyone
> associated with jpackage.org, and Spacewalk is dependent on jpackage, I'm

I dropped an email to Fernando about the domain's DNS.
Comment 3 Jan Pazdziora 2013-05-13 05:02:01 EDT
(In reply to comment #1)
> 
> [root@athlonz yum.repos.d]# cat jpackage-generic.repo 
> [jpackage-generic]
> name=JPackage generic
> baseurl=http://mirrors.dotsrc.org/pub/jpackage/5.0/generic/free/
> #mirrorlist=http://www.jpackage.org/mirrorlist.
> php?dist=generic&type=free&release=5.0
> enabled=1
> gpgcheck=1
> gpgkey=http://www.jpackage.org/jpackage.asc

You still reference the key here. You can set gpgcheck=0 or grab a cached version of this URL from Google, put it to local file, and point gpgkey to it.

I hope the issue is transient, so I'm not updating the HowToInstall page just now. If the problem persists, we will likely put the jpackage.asc to Spacewalk wiki and point the baseurl to the mirror to keep installations running.
Comment 4 Jan Pazdziora 2013-05-14 03:39:01 EDT
The www.jpackage.org site is back.
Comment 5 Eric Herget 2017-09-28 14:08:47 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.