This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 962212 - brcmsmac divide-by-zero (?) in brcms_c_calc_frame_time
brcmsmac divide-by-zero (?) in brcms_c_calc_frame_time
Status: CLOSED DUPLICATE of bug 962211
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 11:33 EDT by Daniel Stone
Modified: 2013-05-13 09:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 09:16:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Stone 2013-05-12 11:33:02 EDT
Every so often (at least hourly today) with 3.9.1-301.fc19, I see what seems to be a divide-by-zero in brcms_c_calc_frame_time(), called from brcms_c_compute_rtscts_dur().  This is on a mid-2012 Ivy Bridge MacBook Air, with a BRCM43224 chip.

Probably notable is that I have an _extremely_ marginal connection to the AP: if I move out of my bedroom, I can't even see it beaconing anymore, and I get quite frequent and long dropouts.  So this is probably quite pathological in terms of retry/etc behaviour.

As it's a hard panic, I don't have any saved OOPSes, but I hope you enjoy the attached picture, with all the quality of a five-year old phonecam, because it was taken with a five-year old phone.

Please let me know if there's anything more I can do: unfortunately I can't get the kernel source for any further debugging, since this connection is so bad and rarely lasts long enough before OOPSing to download much anything ...
Comment 1 Josh Boyer 2013-05-13 09:16:48 EDT

*** This bug has been marked as a duplicate of bug 962211 ***

Note You need to log in before you can comment on or make changes to this bug.