Bug 962226 - 'prove' tests failures
'prove' tests failures
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
mainline
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 14:55 EDT by John Smith
Modified: 2014-04-17 09:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:12:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DEBUG=1 prove foo.t uotput of the failed tests. (3.55 KB, application/x-gzip)
2013-05-12 14:55 EDT, John Smith
no flags Details
'DEBUG=1 prove foo.t' output of the failed tests. (3.28 KB, application/x-gzip)
2013-05-15 08:28 EDT, John Smith
no flags Details
patch files to bug-808400-fcntl.c and bug-808400-flock.c (10.00 KB, application/x-tar)
2013-05-15 17:37 EDT, John Smith
no flags Details
failing even after applying patch output (1.54 KB, application/x-gzip)
2013-05-15 18:02 EDT, John Smith
no flags Details

  None (edit)
Description John Smith 2013-05-12 14:55:43 EDT
Created attachment 746941 [details]
DEBUG=1 prove foo.t uotput of the failed tests.

Description of problem:
Running the 'prove' tests on my machine results in some failures.

Version-Release number of selected component (if applicable):
git clone as of today (12-5-2013)

How reproducible:
always

Steps to Reproduce:
1. ./run-tests.sh
  
Actual results:
Failure for these tests :
./tests/bugs/bug-808400-dist.t
./tests/bugs/bug-808400-repl.t
./tests/bugs/bug-808400-stripe.t
./tests/bugs/bug-808400.t
./tests/bugs/bug-823081.t
./tests/bugs/bug-858242.t
./tests/bugs/bug-882278.t
./tests/bugs/bug-888174.t
./tests/bugs/bug-921072.t

Expected results:
All tests passed
Comment 1 John Smith 2013-05-15 08:28:34 EDT
Created attachment 748247 [details]
'DEBUG=1 prove foo.t' output of the failed tests.

As recommended by Vijay Bellur: By setting the hostname to something other than 'localhost' ('lbalbalba'), the following two tests succeed:

./tests/bugs/bug-888174.t 
./tests/bugs/bug-882278.t 


The others still fail.
Comment 2 John Smith 2013-05-15 17:37:13 EDT
Created attachment 748521 [details]
patch files to bug-808400-fcntl.c and bug-808400-flock.c

changing the 'fstat' call in ./bug-808400-fcntl.c and ./bug-808400-flock.c to 'fstat64' seems to solve the issue.
Comment 3 John Smith 2013-05-15 18:02:24 EDT
Created attachment 748524 [details]
failing even after applying patch output

Even after applying the supplied patches, the following two tests still fail: 

./tests/bugs/bug-823081.t 
./tests/bugs/bug-921072.t
Comment 4 Anand Avati 2013-05-19 04:47:27 EDT
REVIEW: http://review.gluster.org/5034 (Tests: changing calls from 'fstat' to 'fstat64' fixes these tests on 32 bit platforms: bug-858242.t, bug-808400*.t) posted (#1) for review on master by John Smith (lbalbalba@gmail.com)
Comment 5 Anand Avati 2013-05-19 09:07:03 EDT
COMMIT: http://review.gluster.org/5034 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b6e78710bfe0905bdaae8ef4fadd2a676f44bdfe
Author: John Smith <lbalbalba@gmail.com>
Date:   Sat May 18 21:01:50 2013 +0200

    Tests: changing calls from 'fstat' to 'fstat64' fixes these tests on 32 bit platforms: bug-858242.t, bug-808400*.t
    
    Change-Id: Ifd85c711a8d16eb3ef17bd1c585acdc34121b12d
    BUG: 962226
    Signed-off-by: John Smith <lbalbalba@gmail.com>
    Reviewed-on: http://review.gluster.org/5034
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2013-05-19 13:58:26 EDT
REVIEW: http://review.gluster.org/5036 (tests: this fixes test bug-823081.t for bug-962226) posted (#1) for review on master by John Smith (lbalbalba@gmail.com)
Comment 7 Anand Avati 2013-05-23 04:51:29 EDT
REVIEW: http://review.gluster.org/5073 (tests: changing 'localhost' to  fixes 'access denied' for tests/bugs/bug-921072.t) posted (#1) for review on master by John Smith (lbalbalba@gmail.com)
Comment 8 Anand Avati 2013-05-23 05:00:40 EDT
REVIEW: http://review.gluster.org/5073 (tests: changing 'localhost' to  fixes 'access denied' for tests/bugs/bug-921072.t) posted (#2) for review on master by John Smith (lbalbalba@gmail.com)
Comment 9 Anand Avati 2013-05-23 05:03:23 EDT
REVIEW: http://review.gluster.org/5073 (tests: changing 'localhost' to '$H0' fixes 'access denied' for tests/bugs/bug-921072.t) posted (#3) for review on master by John Smith (lbalbalba@gmail.com)
Comment 10 Anand Avati 2013-05-23 05:32:05 EDT
REVIEW: http://review.gluster.org/5036 (tests: Change 'volume create' to 'volume create force') posted (#2) for review on master by John Smith (lbalbalba@gmail.com)
Comment 11 Anand Avati 2013-05-23 10:43:36 EDT
COMMIT: http://review.gluster.org/5036 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit a387a545b44a553b9aedf1e2f4683c84dee0e6be
Author: John Smith <lbalbalba@gmail.com>
Date:   Sun May 19 19:57:04 2013 +0200

    tests: Change 'volume create' to 'volume create force'
    
    Using 'force' when creating volumes prevents errors when creating bricks in the root partition. This fixes test bug-823081.t for bug-962226
    
    Change-Id: I00996e1ab76713084076507d0aebdb65edc806c8
    BUG: 962226
    Signed-off-by: John Smith <lbalbalba@gmail.com>
    Reviewed-on: http://review.gluster.org/5036
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
Comment 12 Anand Avati 2013-11-26 03:19:09 EST
REVIEW: http://review.gluster.org/6356 (tests: Change 'volume create' to 'volume create force') posted (#1) for review on release-3.4 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 13 Anand Avati 2013-11-27 00:39:36 EST
COMMIT: http://review.gluster.org/6356 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 88dc9d88990d75637b144ca11d3510c8fb7e3f0b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Nov 26 13:48:06 2013 +0530

    tests: Change 'volume create' to 'volume create force'
    
    Using 'force' when creating volumes prevents errors when creating
    bricks in the root partition.
    This fixes test bug-823081.t for bug-962226
    
    Change-Id: I210ffda6bdc2cced4bd54755a2b44fdfd05b813b
    Original-author: John Smith <lbalbalba@gmail.com>
    BUG: 962226
    Signed-off-by: John Smith <lbalbalba@gmail.com>
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/6356
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 14 Niels de Vos 2014-04-17 09:12:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.