Bug 962229 - gvfsd-metadata loops and constantly creates and deletes log files in ~/.local/share/gvfs-metadata/
gvfsd-metadata loops and constantly creates and deletes log files in ~/.local...
Status: CLOSED DUPLICATE of bug 561904
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 15:35 EDT by Martin
Modified: 2015-03-03 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 06:03:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace (10.86 KB, application/octet-stream)
2013-05-12 15:35 EDT, Martin
no flags Details
strace (5.59 KB, application/octet-stream)
2013-05-12 15:35 EDT, Martin
no flags Details

  None (edit)
Description Martin 2013-05-12 15:35:21 EDT
Created attachment 746964 [details]
GDB backtrace

Description of problem:
gvfsd-metadata loops and constantly creates and deletes log files in ~/.local/share/gvfs-metadata/

Version-Release number of selected component (if applicable):
gvfs-1.14.2-3.fc18.x86_64

How reproducible:
randomly
  
Actual results:
gvfsd-metadata eats 40 % of CPU and constantly writes around 16 MB/s on my SSD!

Additional info:

[martix@martix ~]$ ls /home/martix/.local/share/gvfs-metadata/
home  home-e90557d9.log  home.RYLZZW  root  root-a7da8133.log  uuid-2a6fc695-4bfe-4709-9c1a-be662a0ff8c5  uuid-2a6fc695-4bfe-4709-9c1a-be662a0ff8c5-ce546afc.log
[martix@martix ~]$ ls /home/martix/.local/share/gvfs-metadata/
home  home-d4aef8e8.log  home.XJE1ZW  root  root-a7da8133.log  uuid-2a6fc695-4bfe-4709-9c1a-be662a0ff8c5  uuid-2a6fc695-4bfe-4709-9c1a-be662a0ff8c5-ce546afc.log
Comment 1 Martin 2013-05-12 15:35:50 EDT
Created attachment 746965 [details]
strace
Comment 2 Tomáš Bžatek 2013-05-13 06:03:09 EDT
(In reply to comment #0)
> gvfsd-metadata eats 40 % of CPU and constantly writes around 16 MB/s on my
> SSD!

Cool, at least the SSD manufacturers realize that lowering durability every new manufacturing process is the wrong way.

*** This bug has been marked as a duplicate of bug 561904 ***
Comment 3 Elliott Forney 2013-05-13 15:03:11 EDT
> Cool, at least the SSD manufacturers realize that lowering
> durability every new manufacturing process is the wrong way.

Doesn't seem appropriate to me to slam SSD manufacturers when it is gvfsd that is broken.  They design for the typical use-cause, not for software that gets caught in a loop writing to disk.  If you want an ultra durable disk, buy an expensive SAS drive.
Comment 4 Tomáš Bžatek 2013-05-14 11:40:46 EDT
(In reply to comment #3)
> > Cool, at least the SSD manufacturers realize that lowering
> > durability every new manufacturing process is the wrong way.
> 
> Doesn't seem appropriate to me to slam SSD manufacturers when it is gvfsd
> that is broken.  They design for the typical use-cause, not for software
> that gets caught in a loop writing to disk.  If you want an ultra durable
> disk, buy an expensive SAS drive.

Indeed, my comment was sarcasm. Such bugs happen from time to time.

Note You need to log in before you can comment on or make changes to this bug.