Bug 962244 - USB Mass Storage Device (INSTALLATION MEDIA created with DD) is available as a disk and even if not selected, it shows up in custom partitioning with a 0b iso9660 entry
USB Mass Storage Device (INSTALLATION MEDIA created with DD) is available as ...
Status: CLOSED DUPLICATE of bug 960794
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 19:30 EDT by Reartes Guillermo
Modified: 2014-09-05 17:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-05 17:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot F19b TC4 (65.49 KB, image/png)
2013-05-12 19:30 EDT, Reartes Guillermo
no flags Details
screenshot F19b TC4, custom partitioning (85.83 KB, image/png)
2013-05-12 19:32 EDT, Reartes Guillermo
no flags Details
anaconda.log (12.30 KB, text/plain)
2013-05-14 22:06 EDT, Reartes Guillermo
no flags Details
program.log (8.86 KB, text/plain)
2013-05-14 22:07 EDT, Reartes Guillermo
no flags Details
storage.log (39.35 KB, text/plain)
2013-05-14 22:07 EDT, Reartes Guillermo
no flags Details
syslog (81.42 KB, text/plain)
2013-05-14 22:08 EDT, Reartes Guillermo
no flags Details
wind u100 screenshot (93.54 KB, text/plain)
2013-05-14 22:12 EDT, Reartes Guillermo
no flags Details
anaconda.log (17.72 KB, text/plain)
2013-05-14 22:36 EDT, Reartes Guillermo
no flags Details
program.log (17.60 KB, text/plain)
2013-05-14 22:36 EDT, Reartes Guillermo
no flags Details
storage.log (63.24 KB, text/plain)
2013-05-14 22:37 EDT, Reartes Guillermo
no flags Details
syslog (97.60 KB, text/plain)
2013-05-14 22:37 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-12 19:30:39 EDT
Created attachment 747021 [details]
screenshot F19b TC4

Description of problem:

USB Mass Storage Device (F19b TC4 Installation Media) is available as a disk 
in INSTALLATION DESTINATION and it is the first item show.

Selecting only 'sda' in INSTALLATION DESTINATION results in a 0b entry
corresponding to sdb shown in CUSTOM PARTITIONING. Disk 'sdb' was
not selected so it should not appear there.

Version-Release number of selected component (if applicable):
F19b TC4

How reproducible:
always

Steps to Reproduce:
1. DD Fedora is to an USB Mass Storage Device
2. Reach Storage Installation Destination
3. Select only sda
4. Do CUSTOM PARTITIONING, partition scheme 'standard partition'
  
Actual results:
0b entry in custom partitioning, and the device appears even if it should not.

Expected results:
Only selected disks should be available to use as a INSTALLATION DESTINATION.
Comment 1 Reartes Guillermo 2013-05-12 19:32:05 EDT
Created attachment 747022 [details]
screenshot F19b TC4, custom partitioning

only sda was selected, but sdb has that 0b entry (iso9660).
Comment 2 Brian Lane 2013-05-14 20:57:06 EDT
logs please.
Comment 3 Reartes Guillermo 2013-05-14 22:06:37 EDT
Created attachment 748024 [details]
anaconda.log
Comment 4 Reartes Guillermo 2013-05-14 22:07:06 EDT
Created attachment 748025 [details]
program.log
Comment 5 Reartes Guillermo 2013-05-14 22:07:30 EDT
Created attachment 748026 [details]
storage.log
Comment 6 Reartes Guillermo 2013-05-14 22:08:41 EDT
Created attachment 748027 [details]
syslog

These logs are from another affected netbook, wind u100. (the screenshots are from an eee 701).
Comment 7 Reartes Guillermo 2013-05-14 22:12:30 EDT
Created attachment 748028 [details]
wind u100 screenshot

please discard previously attached logfiles, as the screenshots shows, it is a different issue. My mistake.

I will attach the correct ones in a momment.
Comment 8 Reartes Guillermo 2013-05-14 22:36:11 EDT
Created attachment 748032 [details]
anaconda.log
Comment 9 Reartes Guillermo 2013-05-14 22:36:35 EDT
Created attachment 748033 [details]
program.log
Comment 10 Reartes Guillermo 2013-05-14 22:37:04 EDT
Created attachment 748034 [details]
storage.log
Comment 11 Reartes Guillermo 2013-05-14 22:37:29 EDT
Created attachment 748035 [details]
syslog
Comment 12 Reartes Guillermo 2013-05-14 22:43:14 EDT
I could not reproduce it in the original netbook, i got the same results that with the wind u100. 

I believe that the difference is made by the sdcard slot being non populated.
The first time (when i reported it) the netbook ssd was empty (it was trashed by another issue).

I current case, there is a detected F19 instance being shown in custom partitioning. The 0b iso9960 entry is now unknown.
Comment 13 David Shea 2014-09-05 17:02:01 EDT
The 0b /dev/sdb1 device that is appearing is also appearing with no media, so this is fixed by the fix for bug 960794

*** This bug has been marked as a duplicate of bug 960794 ***

Note You need to log in before you can comment on or make changes to this bug.