Bug 962255 - Squid linked openssl, Its license problem.
Squid linked openssl, Its license problem.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-05-12 21:51 EDT by mejiko
Modified: 2013-05-12 22:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-12 22:49:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 251988 None None None Never

  None (edit)
Description mejiko 2013-05-12 21:51:19 EDT
Hello.

Squid licensed under GPL, but linked openssl.
OpenSSL license is incompatible GPL. 

Its non-free, because license problem.


Suggests:


1. Remove openssl support and rebuild. (Its simple)

2. replace GPL compatible library (Example: nss, gnutls, etc...) but Im not tested.

Note: GNUTLS is licensed under LGPL, nss is licensed under MPL version 2.0.

3. Contact Upstream author.

4. Remove Fedora repos.


Thanks.


Reference:

https://fedoraproject.org/wiki/Licensing:FAQ?rd=Licensing/FAQ#What.27s_the_deal_with_the_OpenSSL_license.3F

https://www.gnu.org/licenses/license-list.html#OpenSSL

http://bugs.squid-cache.org/show_bug.cgi?id=2741

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=251988

https://bugzilla.redhat.com/show_bug.cgi?id=348261
Comment 1 mejiko 2013-05-12 21:51:57 EDT
Blocking FE-Legal, this is license problem.
Comment 3 Henrik Nordström 2013-05-12 22:49:28 EDT
It is not seen as a license problem for Fedora where OpenSSL is considered as a system library. See the same Fedora Licensing FAQ link you posted.

There is however a policy decision to use a common TLS framework (NSS) and there is a existing bug report for that as you already found.

Feel free to reopen to continue discussion if you disagree with my understanding of Fedora Licensing requirements.

Note You need to log in before you can comment on or make changes to this bug.