Bug 962275 - glusterd: 'gluster peer probe <hostname/ip>' - able to add peer which is already part of cluster
glusterd: 'gluster peer probe <hostname/ip>' - able to add peer which is alre...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 01:03 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 05:02:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-05-13 01:03:50 EDT
Description of problem:
glusterd: 'gluster peer probe <hostname/ip>' - able to add peer which is already part of cluster

Version-Release number of selected component (if applicable):
3.4.0.6rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.from one RHS node peer probe all other RHS node
[root@cutlass ~]# gluster peer probe fred.lab.eng.blr.redhat.com
peer probe: success
[root@cutlass ~]# gluster peer probe fan.lab.eng.blr.redhat.com
peer probe: success
[root@cutlass ~]# gluster peer probe mia.lab.eng.blr.redhat.com
peer probe: success

2.verify peer connection from all peers using 'gluster peer status'
3.from another RHS node again peer probe existing peer
[root@fred ~]# gluster peer probe cutlass.lab.eng.blr.redhat.com
peer probe: success

  
Actual results:
peer probe is successful. 

Expected results:
It should fail with error message saying that peer is already part of cluster

Additional info:
Comment 4 Amar Tumballi 2013-05-16 05:02:44 EDT
Rachana,

Notice that this would work even though its part of the cluster because we would update the 'hostname' part of the peer list from that RHS node.

To verify, please check 'peer status' before and after the 'peer probe'.

Currently its working as designed, so marking it as not a bug.

Note You need to log in before you can comment on or make changes to this bug.