Bug 962287 - [RFE] support a timeout option to rhts-sync-block
[RFE] support a timeout option to rhts-sync-block
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.12
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 02:12 EDT by Nick Coghlan
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 02:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2013-05-13 02:12:37 EDT
If the target state is never achieved on one or more named systems, rhts-sync-block will halt the recipe until the local or external watchdog times out.

It would be useful if a timeout option could be specified, such that rhts-sync-block would terminate with a zero error code if the desired state was achieved and a non-zero error code if the timeout was reached.
Comment 2 Nick Coghlan 2013-05-13 02:19:11 EDT
Turns out this was added last year, I was just updating a section of the docs that claimed it didn't exist.

Note You need to log in before you can comment on or make changes to this bug.