Bug 962320 - Remoting testsuite: Intermittent hang of RemoteSslChannelTest
Remoting testsuite: Intermittent hang of RemoteSslChannelTest
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: David M. Lloyd
:
Depends On:
Blocks: 996500
  Show dependency treegraph
 
Reported: 2013-05-13 04:00 EDT by Richard Janík
Modified: 2014-10-25 08:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 08:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Janík 2013-05-13 04:00:51 EDT
Description of problem:

Seen in EAP 6.1.0.ER8 with Remoting version 3.2.16.GA.

Test case RemoteSslChannelTest randomly hangs. Although there is nothing interesting, the hang can be seen here: https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Remoting/job/eap-6x-remoting-windows-matrix-downstream/71/jdk=java16_default,label=Win2k8r2_x86_64/console

I haven't seen this with other versions of EAP where Remoting is 3.2.16.GA nor with any other platform with ER8. It happens rarely.
Comment 1 Radoslav Husar 2013-05-13 04:27:35 EDT
Correcting component.

@Richard, please use component "Remoting" and peferably say in the description that this is about the component testuite. Thanks!
Comment 2 Navin Surtani 2013-08-15 05:43:39 EDT
I ran this test locally over several iterations (30 times) on sun/oracle jdk versions 6, 7 and 8. I have not seen any failures as yet. If someone can reproduce this failure consistently then please post up.
Comment 3 Radoslav Husar 2013-08-15 06:37:12 EDT
@Navin, if I am reading this right, the problem was seen on Windows 2008 (Sun JDK1.6) so I am assuming this is Windows-only. What OS did you test with?
Comment 4 Navin Surtani 2013-08-15 07:18:48 EDT
@Rado - I ran it on my PC which is Windows 7.
Comment 5 Radoslav Husar 2013-08-15 08:12:47 EDT
@Navid, hm, might not be it, but W7 still is not a supported system https://access.redhat.com/site/articles/111663 You'd need a W2008 or so.

@Richard, do you still see the failure in 6.1.1?
Comment 6 Richard Janík 2013-08-15 08:23:54 EDT
No, I haven't seen this for quite some time, definitely not in 6.1.1 builds.
Comment 7 Radoslav Husar 2013-08-15 08:44:23 EDT
I suppose we can close this as fixed along the way.
Comment 9 Navin Surtani 2013-08-16 02:32:46 EDT
@Rado - yeah I realise that Win7 isn't a supported platform. I don't have any access to a Windows 2008 machine locally. I figured that if there was a generic Windows problem then I'd be likely to see it there as well. Alas, it wasn't to be however.
Comment 11 Ladislav Thon 2014-09-10 08:27:30 EDT
Closing as notabug per comment 10.

Note You need to log in before you can comment on or make changes to this bug.