Bug 962325 - gnome-boxes-3.8.1.2-1.fc19.armv7hl requires libvirt-daemon-kvm
gnome-boxes-3.8.1.2-1.fc19.armv7hl requires libvirt-daemon-kvm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-boxes (Show other bugs)
19
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 04:17 EDT by Pavel Holica
Modified: 2013-05-31 23:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: gnome-boxes-3.8.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 23:13:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Holica 2013-05-13 04:17:40 EDT
Description of problem:
There's a missing dependency in gnome-boxes. It requires libvirt-daemon-kvm, but there's no such package on arm.

Version-Release number of selected component (if applicable):
arm Fedora 19 Alpha RC5

How reproducible:
always

Steps to Reproduce:
1. Start vnc installation using http://armpkgs.fedoraproject.org/mash/stage/19-Alpha-RC5/Fedora/armhfp/os/ source
2. Wait for repodata to be processed
3. Go to software selection and click on warning message on the bottom of the screen.
  
Actual results:
gnome-boxes-3.8.1.2-1.fc19.armv7hl requires libvirt-daemon-kvm

Expected results:
gnome-boxes shouldn't require libvirt-daemon-kvm on arm

Additional info:
Comment 1 Pavel Holica 2013-05-13 04:19:41 EDT
Just thinking about it now, gnome-boxes shouldn't require this package on any arch, since it's not needed for its functionality (managing remote or local virtual machines).
Comment 2 Christophe Fergeau 2013-05-14 06:31:24 EDT
it's required when creating new VMs (at least for if you want them to have good performance).
Comment 3 Daniel Berrange 2013-05-14 06:39:31 EDT
Hmm, kernel >= 3.8 and QEMU >= 1.5.0 will be able to support KVM on armv7. Not sure if QEMU 1.5.0 will get into F19 though. At least by Fedora 20 though we'll be able to have libvirt-daemon-kvm exist on ARM too.
Comment 4 Pavel Holica 2013-05-14 08:56:03 EDT
Yes, but for Fedora 19, this blocks Gnome installation in anaconda, which is default.
Comment 5 Daniel Berrange 2013-05-14 08:57:28 EDT
Boxes should just make their dep on libvirt-daemon-kvm be conditional on x86 arch as a quick fix.
Comment 6 Zeeshan Ali 2013-05-14 09:50:15 EDT
(In reply to comment #5)
> Boxes should just make their dep on libvirt-daemon-kvm be conditional on x86
> arch as a quick fix.

Since Boxes doesn't really support ARM anyways, I think Boxes should simply be excluded from ARM builds for now.
Comment 7 Pavel Holica 2013-05-15 04:15:03 EDT
How it doesn't support arm? I haven't tried it on arm yet, but the project page says, that it's capable of doing more then managing local VMs (https://live.gnome.org/Boxes).

I believe that it can be used same way as virt-manager to manage remote VMs, and I use it that way on HW without virtualization support.
Comment 8 Pavel Holica 2013-05-23 04:28:34 EDT
Hello, is there any update on this bug? Thanks.
Comment 9 Christophe Fergeau 2013-05-23 05:20:04 EDT
(In reply to Pavel Holica from comment #7)
> How it doesn't support arm? I haven't tried it on arm yet, but the project
> page says, that it's capable of doing more then managing local VMs
> (https://live.gnome.org/Boxes).
> 
> I believe that it can be used same way as virt-manager to manage remote VMs,
> and I use it that way on HW without virtualization support.

In theory it should be able to do that, in practice, the current UI and testing were pretty much centered around "easily create new VMs and manage these VMs".
The UI to access remote VMs is really bad, it's not tested a lot, VM creation on ARM is untested, and probably needs libvirt work as well, ...
For all these reasons, it's imo better not to build Boxes on non-x86/x86_64 arches for now.

Testing/patches are very welcome to improve the !x86 support in Boxes though!
Comment 10 Christophe Fergeau 2013-05-23 05:24:12 EDT
I'll add this to the .spec if noone objects:

# While qemu/kvm may be available on more arch than x86, VM creation is very
# likely not to work as expected, and non-local VM management needs love to
# be a first class citizen in Boxes. For these reasons, it's better not to
# build Boxes on non-x86 for now
%if 0%{?fedora}
ExclusiveArch: %{ix86} x86_64
%endif
Comment 11 Pavel Holica 2013-05-23 06:08:10 EDT
Thanks for response. I've installed it now and I'll give it a try :)
Comment 12 Fedora Update System 2013-05-23 09:53:52 EDT
gnome-boxes-3.8.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-boxes-3.8.2-3.fc19
Comment 13 Fedora Update System 2013-05-23 15:59:32 EDT
Package gnome-boxes-3.8.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-boxes-3.8.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9004/gnome-boxes-3.8.2-3.fc19
then log in and leave karma (feedback).
Comment 14 Dan Horák 2013-05-24 03:59:41 EDT
Adding the ExclusiveArch: x86-only tag is creating new problems for non-x86 arches where the last existing build (with wrong Requires for ARM) will be included in the repositories. It's not possible to exclude a package that already existed in a secondary arch with the current tools. Also the GNOME group in comps marks gnome-boxes as "required" causing broken deps again when we exclude gnome-boxes somehow. So the better solution is making just the Requires: libvirt-daemon-kvm depend on the qemu_kvm_arches variable and drop the ExclusiveArch in Fedora.
Comment 15 Fedora Update System 2013-05-24 05:46:51 EDT
gnome-boxes-3.8.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-boxes-3.8.2-4.fc19
Comment 16 Fedora Update System 2013-05-27 18:53:38 EDT
gnome-boxes-3.8.2-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-boxes-3.8.2-5.fc19
Comment 17 Fedora Update System 2013-05-28 14:23:28 EDT
gnome-boxes-3.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-boxes-3.8.3-1.fc19
Comment 18 Fedora Update System 2013-05-31 23:13:56 EDT
gnome-boxes-3.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.