This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 962333 - Often meets Node execution failure when creating jenkins app with small node size on ex-std-node1.stg.rhcloud.com
Often meets Node execution failure when creating jenkins app with small node ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 04:47 EDT by Meng Bo
Modified: 2015-05-14 19:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-05-13 04:47:08 EDT
Description of problem:
Create jenkins server on stage, often meet Node execution failure and app cannot be created successfully. Suspect that one of the small nodes on stage has some problems.

Create jenkins app with medium gear size will get successful everytime.
Create jenkins app with small gear size will get successful sometimes.

For the succeed ones, login to the app and get the node host name:
[jenkins-stgtest1.stg.rhcloud.com 5190a2d82587c82979000082]\> hostname
ex-std-node2.stg.rhcloud.com


Version-Release number of selected component (if applicable):
STG (devenv-stage_251)

How reproducible:
often

Steps to Reproduce:
1.Create jenkins with small gear size
2.
3.
  
Actual results:

Creating application 'jenkins' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..


Expected results:
Jenkins creation should get successful everytime.

Additional info:
Comment 1 manoj 2013-07-22 12:15:53 EDT
jenkins timeout was changed. Can you check if this is still broken?
Comment 2 Meng Bo 2013-07-23 05:32:52 EDT
Checked on current stage, with several times creation and deletion.

No exception appears when creating and deleting jenkins server on each node.

[root@localhost openshiftest]# cat node.log |grep node1
[51ee1feb2587c87d84000056 jenkins-1.4] ex-std-node1.stg.rhcloud.com
[51ee36e6dbd93ce4df000095 jenkins-1.4] ex-std-node1.stg.rhcloud.com
[51ee37e02587c8e95b00068e jenkins-1.4] ex-std-node1.stg.rhcloud.com

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.