Bug 962393 - Dashbuilder does not support all DBs required by PRD
Dashbuilder does not support all DBs required by PRD
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.0
Assigned To: Roger Martínez
Jan Hrcek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 06:50 EDT by Jan Hrcek
Modified: 2014-08-06 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: PostgreSQL 9.1 was already supported. IBM DB2 9.7 was not supported. Consequence: Cannot run in IBM DB2 9.7 Fix: Added IBM DB2 9.7 support and tested. Result: Dashbuilder & jBPM dashbuilder are working now in IBM DB2 9.7
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-05-13 06:50:51 EDT
Description of problem:

Based on latest BRMS/BPMS PRD (see https://docspace.corp.redhat.com/docs/DOC-122826) the dashbuilder should support the following databases:

H2
Oracle 11g 
MS SQL Server 2008
IBM DB2 9.7
MySQL 5.1 & 5.5
PostgreSQL 8.4 & 9.1
RHEL 5.5 PostgreSQL config  8.4 (as delivered)

However based on information from developers (https://bugzilla.redhat.com/show_bug.cgi?id=961679 -> see section: Supported databases) the application currently supports the following databases:
* H2
* Oracle 10g & 11g
* MS SQL Server 2005 & 2008
* MySQL 5.1 & 5.5
* PostgreSQL 8.4
------------
Baded on that the support for following databases/versions is missing:
IBM DB2 9.7
PostgreSQL 9.1
Comment 1 Rajesh Rajasekaran 2013-07-17 12:06:03 EDT
From BZ#961679 it looks like PostgreSQL 9.2 was tested and it works? 
This will not be a blocker from a Beta release perspective, hence setting target milestone to ER2.
Comment 2 Roger Martínez 2013-07-19 11:17:46 EDT
Added IBM DB2 9.7 support and tested.
Comment 4 Jan Hrcek 2013-09-26 04:58:03 EDT
Verified support for PostgreSQL 9.2.

However to we are currently not able to verify support of IBM DB2 9.7. We must wait for eng ops to check block size settings of our DB2 instance, because the application doesn't work with default block size. See https://engineering.redhat.com/rt/Ticket/Display.html?id=249643 so we know
Comment 8 Jan Hrcek 2013-11-14 04:25:30 EST
Finally after some complications (see https://engineering.redhat.com/rt/Ticket/Display.html?id=249643) we were able to get instance of DB2 9.7 that is configured as dashbuilder requires. We managed to get the BPMS (business central + dashbuilder) deployed without errors on DB2 9.7. We are now able to open and login to the dashbuilder UI -> Closing this bugzilla as verified.

However, the smoke test of the dashbuilder failed. New bugzilla will be opened for that issue.

Note You need to log in before you can comment on or make changes to this bug.