Bug 962408 - [PATCH] Rhui-manager is not doing pulp.generate_metadata() in command-line mode "rhui-manager packages upload"
[PATCH] Rhui-manager is not doing pulp.generate_metadata() in command-line mo...
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
2.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.3
Assigned To: dgao
Ina Panova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 07:48 EDT by Ina Panova
Modified: 2013-12-17 15:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update adds a step for generating metadata that was not part of the upload API call. This meant that packages would be associated to a repository but the yum metadata was not updated to reflect the new packages. This caused a yum client to be unable to use these new packages. This was corrected by including the metadata generation in the upload API. The packages are now able to used by a yum client after they are uploaded.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 15:09:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
call pulp.generate_metadata() when performing "rhui-manager packages upload" (1.12 KB, patch)
2013-05-13 07:48 EDT, Ina Panova
no flags Details | Diff

  None (edit)
Description Ina Panova 2013-05-13 07:48:47 EDT
Created attachment 747194 [details]
call pulp.generate_metadata() when performing "rhui-manager  packages upload"

Description of problem:
There is a discrepancy between rhui-manager doing packages upload in command-line("rhui-manager packages upload") and interactive mode. In command-line mode rhui-manager does not call pulp.generate_metadata() at the end of transaction so packages are really never added to the repo and won't be ever synchronized to the CDS.

Version-Release number of selected component (if applicable):
rh-rhui-tools-2.1.19-1.el6_4.noarch


How reproducible:
Always.

Steps to Reproduce:
1. Create custom repo
2. Upload a package in command-line mode "rhui-manager packages upload"
3. Assign this repo to a CDS and sync it
4. Check whether the package is present on CDS.  
  
Actual results:
Package is not present.

Expected results:
Package is present.

Additional info:
Patch attached.
Comment 1 dgao 2013-09-24 13:54:30 EDT
Commit: 1542475d764897ebb237873003be051e0bc254bc

rhui-manager packages upload --repo_id test_content_repo --packages /home/ec2-user/rh-amazon-rhui-client-2.2.87-1.el6_4.noarch.rpm
Uploading /home/ec2-user/rh-amazon-rhui-client-2.2.87-1.el6_4.noarch.rpm...

less /var/lib/pulp/repos/test_content_repo/repodata/5716eca3c6f499ddc94cdd7ae8c21aad49738815081e575c3e51a0cc37b0c188-filelists.xml.gz

<?xml version="1.0" encoding="UTF-8"?>
<filelists xmlns="http://linux.duke.edu/metadata/filelists" packages="1">
<package pkgid="7b70b6de1524fc773404c453a42468cf62fa708c0f9bbb943bb9ecfeea782056" name="rh-amazon-rhui-client" arch="noarch">
    ...
</package>

</filelists>
Comment 2 Ina Panova 2013-11-04 06:33:06 EST
tested in rh-rhui-tools-2.1.27-1.el6_4.noarch

Move to Verified.
Comment 4 errata-xmlrpc 2013-12-17 15:09:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.