Bug 962417 - Support patch for JBPAPP-10153/HHH-4459 - for EAP 6.0.1
Support patch for JBPAPP-10153/HHH-4459 - for EAP 6.0.1
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: One-off release
Assigned To: Brett Meyer
Zbyněk Roubalík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 08:17 EDT by Adam Kovari
Modified: 2015-09-01 00:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
PATCH NAME: bz-962417 PRODUCT NAME: JBoss EAP VERSION: 6.0.1.GA SHORT DESCRIPTION: EAP 6.0.1 Support Patch for HHH-4459 LONG DESCRIPTION: EAP 6.0.1 Support Patch for HHH-4459 MANUAL INSTALL INSTRUCTIONS: Backup and remove the following files: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml Extract the patched files by either: Using unzip: unzip -d $JBOSS_HOME/ bz-962417.zip Or by extracting the files from the zip to the following locations: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3-bz-962417.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml Instructions to uninstall: Restore the following files that were backed up before the patch was installed: $JBOSS_HOME/modules/org/hibernate/main/hibernate-core-4.1.6.Final-redhat-3.jar $JBOSS_HOME/modules/org/hibernate/main/module.xml COMPATIBILITY: None DEPENDENCIES: JBoss EAP 6.0.1.GA SUPERSEDES: None SUPERSEDED BY: JBoss EAP 6.1.0 CREATOR: Brett Meyer DATE: 14 June 2013
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 10:34:18 EDT
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patched hibernate-core module (3.85 MB, application/x-zip)
2013-05-13 08:18 EDT, Adam Kovari
no flags Details
Source codes (3.82 MB, application/x-java-archive)
2013-05-13 08:20 EDT, Adam Kovari
no flags Details
patched hibernate module (3.85 MB, application/download)
2013-06-14 14:41 EDT, Brett Meyer
no flags Details
bz-962417.zip (3.85 MB, application/octet-stream)
2013-06-14 18:16 EDT, Brad Maxwell
no flags Details
bz-962417.zip (3.85 MB, application/zip)
2013-06-26 06:00 EDT, Jimmy Wilson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-10153 Major Closed HHH-4459 Query with Composite Primary Key parameter crashes when query cache is on 2014-03-25 06:11:45 EDT

  None (edit)
Description Adam Kovari 2013-05-13 08:17:14 EDT
Backport of HHH-4459 to EAP 6.0.1
Comment 1 Adam Kovari 2013-05-13 08:18:18 EDT
Created attachment 747208 [details]
Patched hibernate-core module
Comment 2 Adam Kovari 2013-05-13 08:20:03 EDT
Created attachment 747210 [details]
Source codes
Comment 3 Brett Meyer 2013-05-13 17:08:34 EDT
Looks like Adam already patched the module.  Assigning to him and completing.  Adam, please let me know if that's incorrect!
Comment 4 Adam Kovari 2013-05-17 03:01:39 EDT
The customer reported that the patch works. QA: please test it
Comment 6 Brett Meyer 2013-06-14 14:39:44 EDT
There was some confusion about the module names (referred to the wrong JBPAPP ticket) in Adam's patch, so I just rebuilt it.

http://git.app.eng.bos.redhat.com/?p=hibernate/hibernate-core.git;a=shortlog;h=refs/heads/BZ-962417_4.1.6.Final
Comment 7 Brett Meyer 2013-06-14 14:41:17 EDT
Created attachment 761402 [details]
patched hibernate module
Comment 8 Brad Maxwell 2013-06-14 18:16:21 EDT
Created attachment 761448 [details]
bz-962417.zip
Comment 9 Zbyněk Roubalík 2013-06-20 02:57:53 EDT
No regressions were found and the issue was verified. QA Passed. 

MD5 sum for tested files:
6c8b51c0b3c5082689367afd453c6949  bz-962417.zip
af02dbaf36916ead03af0161aaf4ab56  hibernate-core-4.1.6.Final-redhat-3-bz-962417.jar
3f3134be93686a8855d79494d0f3c49c  module.xml
Comment 10 Jimmy Wilson 2013-06-26 06:00:00 EDT
Created attachment 765501 [details]
bz-962417.zip
Comment 11 Jimmy Wilson 2013-06-26 06:46:41 EDT
Previously, release engineering took the Doc Text and patch attachment and created a new ZIP with both included.  As of this week, GSS has started doing that instead.  Unfortunately some patches were caught in the middle and bundled after QA had started.  Starting next week, all patches will be sent to QA in this format.  There will be no further post QA changes.

Note You need to log in before you can comment on or make changes to this bug.