Bug 962433 - SELinux is preventing /usr/bin/abrt-action-save-package-data from 'create' accesses on the file core_backtrace.
SELinux is preventing /usr/bin/abrt-action-save-package-data from 'create' ac...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c8610c28e3da83c2fa585564465...
:
: 962435 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 09:35 EDT by JayMac
Modified: 2013-06-13 07:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 07:03:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JayMac 2013-05-13 09:35:03 EDT
Description of problem:
SELinux is preventing /usr/bin/abrt-action-save-package-data from 'create' accesses on the file core_backtrace.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that abrt-action-save-package-data should be allowed create access on the core_backtrace file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-action-sav /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                core_backtrace [ file ]
Source                        abrt-action-sav
Source Path                   /usr/bin/abrt-action-save-package-data
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-ccpp-2.1.2-2.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-92.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.8.11-200.fc18.x86_64 #1 SMP Wed
                              May 1 19:44:27 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-05-13 13:32:44 BST
Last Seen                     2013-05-13 13:32:53 BST
Local ID                      0e08ba83-8ebe-45f5-8a08-b13a02d69d80

Raw Audit Messages
type=AVC msg=audit(1368448373.835:349): avc:  denied  { create } for  pid=17116 comm="abrt-action-gen" name="core_backtrace" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1368448373.835:349): arch=x86_64 syscall=open success=yes exit=ESRCH a0=16e2b20 a1=20241 a2=1b0 a3=11 items=0 ppid=17112 pid=17116 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrt-action-gen exe=/usr/bin/abrt-action-generate-core-backtrace subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrt-action-sav,abrt_t,initrc_tmp_t,file,create

audit2allow

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:file create;

audit2allow -R
require {
	type initrc_tmp_t;
	type abrt_t;
	class file create;
}

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:file create;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.11-200.fc18.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-05-13 11:31:10 EDT
restorecon -R -v /var/tmp/abrt

Should fix this.
Comment 2 Daniel Walsh 2013-05-13 11:31:35 EDT
*** Bug 962435 has been marked as a duplicate of this bug. ***
Comment 3 morgan read 2013-06-11 14:28:16 EDT
Description of problem:
trying to submit a abrt genrerated bug about something else - empathy may be

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport

Note You need to log in before you can comment on or make changes to this bug.