Bug 962456 - [abrt] Xnee-3.15-2.fc18: main: Process /usr/bin/gnee was killed by signal 6 (SIGABRT)
[abrt] Xnee-3.15-2.fc18: main: Process /usr/bin/gnee was killed by signal 6 (...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Xnee (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthieu Saulnier
Fedora Extras Quality Assurance
abrt_hash:bb42f4ca62c5f9caf89cbbd468a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 10:27 EDT by Ben Liblit
Modified: 2013-07-05 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: Xnee-3.16-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 20:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.56 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: cgroup (130 bytes, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: dso_list (8.58 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: environ (2.24 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: maps (27.57 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: open_fds (637 bytes, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: proc_pid_status (793 bytes, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details
File: xsession_errors (2.62 KB, text/plain)
2013-05-13 10:27 EDT, Ben Liblit
no flags Details

  None (edit)
Description Ben Liblit 2013-05-13 10:27:02 EDT
Description of problem:
Immediate failure on launch. Just run "gnee" with no arguments and it crashes right away.

Version-Release number of selected component:
Xnee-3.15-2.fc18

Additional info:
backtrace_rating: 4
cmdline:        gnee
core_backtrace: 
crash_function: main
executable:     /usr/bin/gnee
kernel:         3.8.9-200.fc18.i686
uid:            29364
ureports_counter: 2
var_log_messages: May 13 09:17:35 swan abrt[6458]: Saved core dump of pid 6454 (/usr/bin/gnee) to /var/tmp/abrt/ccpp-2013-05-13-09:17:35-6454 (12345344 bytes)

Truncated backtrace:
Thread no. 1 (0 frames)
Comment 1 Ben Liblit 2013-05-13 10:27:05 EDT
Created attachment 747247 [details]
File: backtrace
Comment 2 Ben Liblit 2013-05-13 10:27:07 EDT
Created attachment 747248 [details]
File: cgroup
Comment 3 Ben Liblit 2013-05-13 10:27:09 EDT
Created attachment 747249 [details]
File: dso_list
Comment 4 Ben Liblit 2013-05-13 10:27:10 EDT
Created attachment 747250 [details]
File: environ
Comment 5 Ben Liblit 2013-05-13 10:27:12 EDT
Created attachment 747251 [details]
File: limits
Comment 6 Ben Liblit 2013-05-13 10:27:14 EDT
Created attachment 747252 [details]
File: maps
Comment 7 Ben Liblit 2013-05-13 10:27:16 EDT
Created attachment 747253 [details]
File: open_fds
Comment 8 Ben Liblit 2013-05-13 10:27:18 EDT
Created attachment 747254 [details]
File: proc_pid_status
Comment 9 Ben Liblit 2013-05-13 10:27:19 EDT
Created attachment 747255 [details]
File: xsession_errors
Comment 10 Matthieu Saulnier 2013-05-15 18:44:14 EDT
Thanks for the bug report
I can't reproduce this bug on F19 (same version of Xnee)
In additional information, have you tested in other DE ?
Comment 11 Ben Liblit 2013-05-20 12:19:59 EDT
I'm not sure exactly what you mean by "other DE".  But I do have a few virtual machines handy:

In a GNOME Shell session under Fedora 17 , gnee crashes immediately, every time.

In a GNOME Shell session under Fedora 18, gnee crashes immediately, every time.

In a GNOME Shell session under Fedora 19 alpha plus all subsequent updates, gnee crashes immediately, every time.

I'm happy to try additional variations if you have something specific in mind.
Comment 12 Matthieu Saulnier 2013-05-24 05:22:18 EDT
sorry I meant DE = Desktop Environment = GNOME, KDE, LXDE, Xfce, etc...
If you have one of these installed on your system, could you try to launch it?
Comment 13 Ben Liblit 2013-05-28 20:35:50 EDT
I installed KDE on my existing Fedora 18 virtual machine.  In a KDE Plasma session, gnee crashes immediately, every time.
Comment 14 Matthieu Saulnier 2013-05-29 13:33:08 EDT
I can't to do more, I've forwarded this report to upstream mailing-list.
Comment 15 Henrik Sandklef 2013-06-04 04:34:22 EDT
Gnee is not maintained anymore but I will try to fix it.

/Henrik (GNU Xnee maintainer)
Comment 16 Henrik Sandklef 2013-06-04 05:39:12 EDT
Installed F18 in a vbox and executed gnee (as compiled on a Ubuntu 13.04) and gnee does not crash.

Here's the gnee binary I launched:
   http://itupw185.itu.chalmers.se/gnee

Can some one else try the binary above?

/h
Comment 17 Matthieu Saulnier 2013-06-04 10:35:12 EDT
Your binary works for me in vm kvm f18
Also I tried gnee from the rpm in f18 repository and it works too (in the same vm)
Comment 18 Ben Liblit 2013-06-04 10:54:41 EDT
The binary offered in comment #16 is for x64-64 (64-bit).  In my original report, I set the "Hardware" field to reflect that I was seeing this on i686 (32-bit).

I've tried the standard RPM-installed gnee on an x86-64 Fedora 19 beta virtual machine.  It works fine.  But the standard RPM-installed gnee still fails consistently on any i386/i686 virtual machine I've tried.  So whatever the problem is, it seems to be 32-bit specific.
Comment 19 Matthieu Saulnier 2013-06-04 12:01:26 EDT
Yep I've forgotten to be more precise: All of my tests are on x86_64 systems
So I'm searching in Fedora buildsystem logs differencies between the build for i686 and x86_64

  http://koji.fedoraproject.org/koji/buildinfo?buildID=383869
Comment 20 Matthieu Saulnier 2013-06-04 12:04:55 EDT
Yep I've forgotten to be more precise: All of my tests are on x86_64 systems
So I'm searching in Fedora buildsystem logs differencies between the build for i686 and x86_64

  http://koji.fedoraproject.org/koji/buildinfo?buildID=383869
Comment 21 Henrik Sandklef 2013-06-05 03:55:30 EDT
F18 (32bit) up and running in a vbox. Gnee is working (CVS latest).

Here's a binary

    http://129.16.213.216/scratch/gnee-32bit

Can you try that?

/h


Packages I had to install to get compilation/linking working:
cvs
libgnomeui-devel.i686 libgnome-devel.i686
libtool automake17 autoconf
xorg-x11-proto-devel.noarch xorg-x11-server-devel.i686 
libxcb-devel.i686 libXtst-devel.i686
mesa-libglapi.i686
mesa-libwayland-egl
mesa-libwayland-egl-devel libwayland-client.i686
Comment 22 Henrik Sandklef 2013-06-05 04:13:48 EDT
Gnee can't record XI events (Xnee can). Will fix that while we're at it.

/h
Comment 23 Henrik Sandklef 2013-06-06 04:17:44 EDT
The latest nightly dist contains the latest sources if you prefer to build as you would when producing the rpm package:

June 06:
   http://129.16.213.45/xnee-build/nightly-dists/xnee-cvs-20130606.tar.gz
Comment 24 Ben Liblit 2013-06-06 10:50:02 EDT
The binary offered in comment #21 works for me.  No crash.
Comment 25 Henrik Sandklef 2013-06-06 17:13:37 EDT
Ok. Thanks a lot!

Will prepare a 3.16 release of Xnee (including the new XI fixes or gnee).
Comment 26 Ben Liblit 2013-06-06 17:17:50 EDT
Excellent.  Thank you for giving this your attention, Henrik!
Comment 27 Henrik Sandklef 2013-06-07 03:10:25 EDT
3.16 dist file:
   ftp://ftp.gnu.org/gnu/xnee/xnee-3.16.tar.gz

Comments:
   http://sandklef.wordpress.com/2013/06/06/gnu-xnee-3-16-no-show-jones-released/



.. many thanks for your work!!!
Comment 28 Matthieu Saulnier 2013-06-20 12:39:40 EDT
Updating the rpm, it will be pushed in few days in repository
Comment 29 Fedora Update System 2013-06-26 13:29:57 EDT
Xnee-3.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/Xnee-3.16-1.fc18
Comment 30 Fedora Update System 2013-06-26 13:32:27 EDT
Xnee-3.16-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/Xnee-3.16-1.fc19
Comment 31 Fedora Update System 2013-06-26 22:07:06 EDT
Package Xnee-3.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Xnee-3.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11800/Xnee-3.16-1.fc18
then log in and leave karma (feedback).
Comment 32 Fedora Update System 2013-07-05 20:53:57 EDT
Xnee-3.16-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2013-07-05 20:55:04 EDT
Xnee-3.16-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.