Bug 962484 - Seeing a 403 when login in and going straight to Manage Organizations
Seeing a 403 when login in and going straight to Manage Organizations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Walden Raines
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 11:46 EDT by Og Maciel
Modified: 2013-07-18 17:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:21:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-05-13 11:46:47 EDT
Description of problem:

I believe the key step here is to login to Katello UI and make sure that no organization is selected by default. Then go straight to Administer >> Organizations. You should see a 403 displayed in the UI.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.7-1.el6.noarch
* candlepin-cert-consumer-tyan-gt24-13.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.7-1.el6.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-all-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.47.c7ac869.el6.noarch
* katello-cli-common-1.4.2-1.git.47.c7ac869.el6.noarch
* katello-common-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-configure-1.4.3-1.git.12.bc3684c.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-glue-pulp-1.4.2-1.git.313.0d31cdb.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.3-4.el6.noarch
* ruby193-rubygem-net-ldap-0.2.2-6.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Spinner shows up where organization names should be

Additional info:
Comment 1 Walden Raines 2013-05-28 15:26:05 EDT
https://github.com/Katello/katello/pull/2379
Comment 2 Walden Raines 2013-05-28 17:54:24 EDT
commit 8271f2c5e50ac410a969d0aca9b86949d8e0e4be
Merge: 374540d 59553b2
Author: Walden Raines <walden@redhat.com>
Date:   Tue May 28 14:53:26 2013 -0700

    Merge pull request #2379 from waldenraines/966708-962484
    
    Fix Manage org link not displayed and 403 if you don't have an organization selected

commit 59553b218eb7a9fd5092c9fd149448137213bcde
Author: Walden Raines <walden@redhat.com>
Date:   Tue May 28 15:08:38 2013 -0400

    962484 - Manage Orgs: remove unnecessary require_org.
Comment 3 Walden Raines 2013-05-30 10:08:01 EDT
commit 4d0727f8092d6496e65a73689ad7915ac3d0d23f
Author: Walden Raines <walden@redhat.com>
Date:   Thu May 23 14:28:25 2013 -0400

    966708 - Menu: show manage orgs link without an org selected.
Comment 4 Walden Raines 2013-05-30 10:09:38 EDT
(In reply to Walden Raines from comment #3)
> commit 4d0727f8092d6496e65a73689ad7915ac3d0d23f
> Author: Walden Raines <walden@redhat.com>
> Date:   Thu May 23 14:28:25 2013 -0400
> 
>     966708 - Menu: show manage orgs link without an org selected.

Wrong bug
Comment 5 Walden Raines 2013-05-30 10:12:06 EDT
commit fc68dbacfc1f694c6a6912bd7039c9acbe842175
Author: Walden Raines <walden@redhat.com>
Date:   Tue May 28 15:08:38 2013 -0400

    962484 - Manage Orgs: remove unnecessary require_org.
Comment 6 Og Maciel 2013-05-31 14:39:59 EDT
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-cert-consumer-qeblade35.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
Comment 7 Mike McCune 2013-07-18 17:21:37 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.