Bug 962488 - RHN needs to recognize 'reboot_requested' errata keyword
RHN needs to recognize 'reboot_requested' errata keyword
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
MR53 (AMS)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Derek Brown
David Spalding
CHG02718
:
: 870135 (view as bug list)
Depends On:
Blocks: 429288
  Show dependency treegraph
 
Reported: 2013-05-13 12:02 EDT by Brooks
Modified: 2015-07-08 16:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 17:16:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
api content (10.04 KB, text/plain)
2013-07-29 13:38 EDT, Derek Brown
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 27943 None None None Never

  None (edit)
Description Brooks 2013-05-13 12:02:59 EDT
Description of problem:
As per requestor, Grant Gainey
"
A lot of customers (see https://bugzilla.redhat.com/show_bug.cgi?id=42928) requested that RH add a way to mark errata as requiring a reboot.

RCM added the capability into errata-tool under https://bugzilla.redhat.com/show_bug.cgi?id=869677 , in March.

Satellite got a bunch of commits from SUSE that take advantage of it, which will be released as part of Satellite5.6.0 in September.

However - currently, Hosted doesn't recognize reboot_requested as a valid errata-keyword, and apparently just ignores it when supplied. This means there's no way for it to get from RCM down to Satellite.
"

In this bug, we need to fix the overlying issue of RHN Classic not recognizing 'reboot_requested' errata keyword.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Every time when reboot_suggested attribute on errata advisories

Steps to reproduce:
1. Push an errata which includes reboot_suggested attribute

  
Actual results:
RHN does not recognize 'reboot_requested' errata keyword, therefore systems that are applicable to receive an errata update that has the 'reboot_requested' errata keyword will not reboot as needed.

Expected results:
RHN recognizes 'reboot_requested' errata keyword so that systems that are Registered to RHN that are applicable to receive an Errata update with this attribute will reboot.

Additional info:

This was requested by Grant Gainey in INC0049406

Other information from Grant that was tabled in INC0049406,
"
The net, as I understand it, is that RCM errata-tooling knows to add the
"reboot_requested" keyword into an errata as of March. However, Hosted
doesn't recognize that as a 'legal' keyword, and so it gets stripped out
when an errata is pushed to Hosted.

Satellite has code/UI that responds to the presence of that keyword - but if
Hosted removes it, Satellite will never see it.

Somewhere in Hosted, in the errata-tool publishing flow, there is a
check for valid-keyword, and "reboot_requested" needs to be added so
that it makes it into Hosted, into the rhnErrataKeyword table. I don't
believe there are any other changes we need.

It looks like maybe the code here

rhn-hosted/backend/src/server/importlib/backend.py

is what's involved? See "def __processObjectCollection__" at ~619. I haven't
ever been in that code myself, so I'm kinda guessing here, sorry :(

Work with dgregor in RCM, it's the communication between errata-tool and Hosted
that needs to be modified.
"
Comment 1 Brooks 2013-05-13 12:04:58 EDT
US34124 added to AMS Backlog. Adding this US, does not indicate bug prioritization status.
Comment 2 Brooks 2013-05-13 12:11:50 EDT
*** Bug 870135 has been marked as a duplicate of this bug. ***
Comment 3 Brooks 2013-07-15 10:13:48 EDT
Derek investigating impacts of this change in MR52.
Comment 4 Derek Brown 2013-07-29 13:38:15 EDT
Created attachment 780033 [details]
api content
Comment 7 David Spalding 2013-08-20 10:12:24 EDT
Tested good on DEV:

https://tcms.engineering.redhat.com/run/77069/
Comment 8 David Spalding 2013-09-04 14:44:17 EDT
Tested good in QA:

https://tcms.engineering.redhat.com/run/81203/
Comment 9 David Spalding 2013-09-15 17:16:03 EDT
This bug was released to production with MR53 RHNrelease on September 13, 2013.

If there's any questions / concerns identified in Production that involves this bug, please email servicedesk@redhat.com , ATTN: AMS in the subject line of the email.

Note You need to log in before you can comment on or make changes to this bug.