Bug 962522 - noUpdatesCheckbox will only work for post-release scenario where 'updates' repo is used, not pre-release where 'updates-testing' is used
noUpdatesCheckbox will only work for post-release scenario where 'updates' re...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 14:43 EDT by Adam Williamson
Modified: 2013-05-24 16:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-19.30-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:18:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-13 14:43:09 EDT
Looking at pyanaconda/ui/gui/spokes/source.py 's noUpdatesCheckbox - the checkbox labelled "Don't install the latest available software updates. Install the default versions provided by the install source above." - it seems to be implemented very simply:

        self._noUpdatesCheckbox.set_active(not self.payload.isRepoEnabled("updates"))

...

    def on_noUpdatesCheckbox_toggled(self, *args):
        """ Toggle the enable state of the updates repo
        """
        if self._noUpdatesCheckbox.get_active():
            self.payload.disableRepo("updates")
        else:
            self.payload.enableRepo("updates")

so, very simply, if it's checked then "updates" is disabled, if it's unchecked then "updates" is enabled.

However, our repo configuration isn't that simple: it's different for pre-releases. For pre-release images, we enable the "fedora" and "updates-testing" repos, because for Branched releases, the "updates" repository is empty, and all 'stable' stuff winds up in the "fedora" repository.

For release images, we enable the "fedora" and "updates" repos, because that's a sensible default (let network installs get 'stable' updates, but not untested stuff from updates-testing).

So I think the behaviour of this checkbox is correct for release images, but not pre-release images. I think it needs to be written in a more sophisticated way, so that on post-release images it toggles the state of the 'updates' repo as it does at present but on pre-release images it toggles the state of the 'updates-testing' repo instead.
Comment 1 Fedora Update System 2013-05-22 14:29:33 EDT
anaconda-19.30-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30-1.fc19
Comment 2 Fedora Update System 2013-05-22 18:39:17 EDT
Package anaconda-19.30-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8871/anaconda-19.30-1.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-05-24 16:18:27 EDT
anaconda-19.30-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.