Bug 962533 - anaconda does not setup an ip address when booting with 'vnc' boot parameter on a wind u100 (without 'vnc' boot parameter the ip address is setup ok)
anaconda does not setup an ip address when booting with 'vnc' boot parameter ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i386 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 15:18 EDT by Reartes Guillermo
Modified: 2013-05-14 21:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 21:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (2.30 KB, text/plain)
2013-05-13 15:18 EDT, Reartes Guillermo
no flags Details
syslog (96.42 KB, text/plain)
2013-05-13 15:19 EDT, Reartes Guillermo
no flags Details
ifcfg.log (490 bytes, text/plain)
2013-05-13 15:20 EDT, Reartes Guillermo
no flags Details
program.log (25.54 KB, text/plain)
2013-05-13 15:20 EDT, Reartes Guillermo
no flags Details
storage.log (81.85 KB, text/plain)
2013-05-13 15:21 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-13 15:18:45 EDT
Created attachment 747374 [details]
anaconda.log

Description of problem:

Boot without 'vnc', anaconda reports that the network 'enp1s0' is connected and with an ip.

Boot with 'vnc', anaconda launches vnc but there is an error about not having an ip and instructions to switch to another vt and setup it.

Switch to vt2 and setup an ip addres. (ethtool confirms that there is link).
Connected via vnc successfully after setting up an ip address.

For some reason this netbook in particular does not get an ip when booting with 'vnc'.

Version-Release number of selected component (if applicable):
F19b TC4

How reproducible:
always (using 'vnc' boot parameter)

Actual results:
when booting with vnc on this netboot, i must switch to vt2 and set an ip address to use vnc.

Expected results:
setup an ip address to the network card.

Additional info:
Comment 1 Reartes Guillermo 2013-05-13 15:19:13 EDT
Created attachment 747375 [details]
syslog
Comment 2 Reartes Guillermo 2013-05-13 15:20:00 EDT
Created attachment 747376 [details]
ifcfg.log
Comment 3 Reartes Guillermo 2013-05-13 15:20:24 EDT
Created attachment 747377 [details]
program.log
Comment 4 Reartes Guillermo 2013-05-13 15:21:03 EDT
Created attachment 747378 [details]
storage.log
Comment 5 Radek Vykydal 2013-05-14 09:58:03 EDT
The logs don't seem to contain any error message, ip address seems to be assigned by the time it is needed for message instructing where to connect to:

19:09:45,448 INFO anaconda.stdout: Starting VNC...
19:09:46,721 INFO anaconda.stdout: The VNC server is now running.
19:09:46,728 WARN anaconda.stdout: 

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


19:09:46,737 INFO anaconda.stdout: Please manually connect your vnc client to 192.168.100.108:1 to begin the install.

The only message I can find in source code (and I guess you are hitting) doesn't talk about setting up the connection, just about finding ip address (<IP ADDRESS>) to connect to. There is quite a chance that by the time you switch to vt the address will have been assigned (iface configured). If it is not, one just needs to wait a bit longer. Is this your case? Did you actually set up the address or just find it out by ip addr as instructed?

I'd guess IP address is assigned both in vnc and non-vnc case, the difference is that in the vnc case it is needed earlier and in your case not available at that time so the hint about how to obtain it appears.
Comment 6 Reartes Guillermo 2013-05-14 21:50:29 EDT
After further testing, i determined that it is a physical issue and not related to Fedora. It seems that the Ethernet port (or the cable) had enough room to loose contact for short amounts of time, a weird coincidence. When i setup the address manually, that was enough vibration to restore the link.

So i will close this a NOTABUG.

Sorry for the inconvenience.
Cheers.

Note You need to log in before you can comment on or make changes to this bug.