Bug 962540 - Sound preferences not persisting A2DP [high fidelity playback] as the hardware profile for my bluetooth head set [NEEDINFO]
Sound preferences not persisting A2DP [high fidelity playback] as the hardwar...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 16:06 EDT by Sudarshan
Modified: 2017-12-06 07:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:16:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtaymans: needinfo? (tr.sudarshan)


Attachments (Terms of Use)

  None (edit)
Description Sudarshan 2013-05-13 16:06:11 EDT
Description of problem:

I use a Kinivo BTH220 bluetooth headset - works fine with every other OS [Win 7 , Mac OS, iOS and Android OS]. I paired the headset and connected it to my RH 6.4 laptop [Lenovo W510] and edited the sound preferences to opt towards A2DP [high fidelity playback] as the hardware profile for my headset. When I close the sound preferences, and reopen it - I see that the option has gone back to HSP/HFP [telephony]. 

Also, when I check out the output pane in sound preferences, I notice that the output gets reset to the internal laptop speakers, and BTH220 as the headset identified, is unchecked. Besides this, the headset also lists that only a Mono output is possibe through the headset when in fact the headset is able to render Stereo output.

Version-Release number of selected component (if applicable): sound preferences in Red Hat 6.4


How reproducible:


Steps to Reproduce:

1. Install Red Hat 6.4 and pair up a bluetooth headset [in my case, Kinivo BTH220] - also ensure the headset is connected to the machine.
2. Right click on the sound icon, and select sound preferences
3. Click on the hardware pane, and select BTH220 [it should already be enabled by now] - Select the 'high fidelity playback [A2DP]' option from the drop down box for 'Profile'. 
4. Click on Output pane and ensure that BTH220 is checked.|
5. Click on Close to close the wizard. Now, Re-open the same sound preferences wizard and check options persisted in steps 3 and 4 above. 
  
Actual results:

6. The chosen options in steps 5 and 6 aren't persisted. 
7. Sound quality as experienced through the headset, as expected, is telephony quality [since HSP/HFP is always persisted irrespective of chosen option]


Expected results:

8. The chosen options in steps 5 and 6 are persisted.
9. Sound quality as experienced through the headset is excellent, and in fact of A2DP quality standards.

Additional info:

Apologies - I couldn't find the relevant component to assign this bug to - as am new to identifying the component concerned in this case.
Comment 2 Nils Philippsen 2013-05-15 05:51:11 EDT
(In reply to comment #0)
> Apologies - I couldn't find the relevant component to assign this bug to -
> as am new to identifying the component concerned in this case.

In that case please use the "distribution" component instead of a random one in the future, thanks!

I'll change the component to "pulseaudio" as it seems to be the most likely candidate from which your problem may originate to me.
Comment 3 Sudarshan 2013-05-15 11:22:13 EDT
Thanks Nils. Sorry - I'm a newbie and wasn't aware of which component to assign to.
Comment 4 RHEL Product and Program Management 2013-10-13 19:37:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Wim Taymans 2016-08-22 10:52:14 EDT
I can't seem to reproduce this in 6.7. 

Paired my mpow.
went to sound config tab
selected A2DP from hardware tab and mpow device
selected mpow in output tab
tested speakers
used gst-launch-1.0 audiotestsrc ! pulsesink
closed sound config
opened sound config, settings were still correct

Ideas?
Comment 6 Jan Kurik 2017-12-06 07:16:29 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.