Bug 962544 - JGroups classes missing in EAP 6
JGroups classes missing in EAP 6
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dereed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 16:25 EDT by dereed
Modified: 2014-01-22 06:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JGRP-1631 Major Resolved Missing classes in maven build 2014-01-22 07:32:56 EST

  None (edit)
Description dereed 2013-05-13 16:25:45 EDT
JGroups jar included in EAP6 is missing a lot of classes from the community jar.

(Everything in org.jgroups.tests.*, including Probe, McastSenderTest/MCastReceiverTest, and LargeState, which are used for debugging problems in EAP clusters).
Comment 3 Paul Gier 2013-05-13 17:16:46 EDT
JGroups 3.0.14.Final-redhat-1 (in eap 6.0.1) has the missing classes, but the newer prod build 3.2.7.Final-redhat-1 (in eap 6.1.0) includes the classes.

The product build uses the maven build for JGroups which changed between those two versions.
https://github.com/belaban/JGroups/commit/1714fd50c9b83e9828a76aeac64521fdc7f00e71
Comment 5 Radoslav Husar 2013-05-14 08:38:19 EDT
Moving on to QA then.
Comment 6 Richard Janík 2013-05-15 03:26:04 EDT
There are some classes missing against the community jar:

org/jgroups/tests/bla$1.class
org/jgroups/tests/bla.class
org/jgroups/tests/bla2.class
org/jgroups/tests/bla3.class
org/jgroups/tests/bla6$Credits.class
org/jgroups/tests/bla6$RandomSender.class
org/jgroups/tests/bla6$Sender.class
org/jgroups/tests/bla6.class

Since the Probe, McastSenderTest/MCastReceiverTest, and LargeState classes are there, I'm setting this to verified.
Comment 7 JBoss JIRA Server 2013-05-17 12:31:37 EDT
Bela Ban <bela@jboss.com> made a comment on jira JGRP-1631

send me a PR if you want the maven build fixed. I don't use maven to build JGroups; I use ant
Comment 10 JBoss JIRA Server 2014-01-22 06:47:33 EST
Bela Ban <bela@jboss.com> updated the status of jira JGRP-1631 to Resolved

Note You need to log in before you can comment on or make changes to this bug.