Bug 962554 - LiveCD fails with "Oh no! Something has gone wrong message" on laptop
LiveCD fails with "Oh no! Something has gone wrong message" on laptop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 16:53 EDT by Gerard Ryan
Modified: 2013-06-05 22:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-bluetooth-3.8.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 22:27:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from journalctl -ba (195.37 KB, text/plain)
2013-05-13 16:53 EDT, Gerard Ryan
no flags Details
Output from journalctl -ba on installed system (281.54 KB, text/plain)
2013-05-14 15:58 EDT, Gerard Ryan
no flags Details

  None (edit)
Description Gerard Ryan 2013-05-13 16:53:14 EDT
Created attachment 747443 [details]
Output from journalctl -ba

Description of problem:
I tried to boot my work laptop with Fedora-Live-Desktop-x86_64-19-Beta-TC4-1.iso on a usb stick, but I get the "Oh no! Something has gone wrong." message every time. I tried with the alpha image also with the same results. XFCE image works fine, and on an installed system from the XFCE image, I was able to install the Gnome group from yum and use that fine. The problem seems to be specific to the desktop livecd.

I've attached the output of journalctl -ba (suggested by halfline on IRC). Let me know if there's anything else I can provide or try.

Version-Release number of selected component (if applicable):
Fedora-Live-Desktop-x86_64-19-Beta-TC4-1.iso

How reproducible:
100% on the tested hardware.

Steps to Reproduce:
1. Use liveusb-creator to put the image on a usb stick (16GB)
2. Boot the machine with it (HP EliteBook 8460p)
3. 
  
Actual results:
GNOME (I think) crashes.

Expected results:
Everything goes swimmingly.
Comment 1 Gerard Ryan 2013-05-14 15:57:59 EDT
Oddly, I'm now getting the same screen on the installed system (even though I wasn't getting it previously. There are abrt notifications overlaying it saying that problems have occurred with gome-shell and gnome-settings-daemon. It says that the problem has been reported, so all I can do is click 'Ignore' on those notifications seemingly.

I'll attach the journalctl output for the installed system, that might provide you with some info hopefully.

I'll also change severity to high, since this hardware is quite common. It's a machine that HP provide to employees of the company that I work for (and probably other large companies where they have IT support contracts) -- it would be a shame to see GNOME not working on such common hardware! :-/

If you want me to test anything, let me know. :)
Comment 2 Gerard Ryan 2013-05-14 15:58:48 EDT
Created attachment 747901 [details]
Output from journalctl -ba on installed system
Comment 3 Matthias Clasen 2013-05-25 21:35:22 EDT
This is gnome-shell crashing.
Comment 4 Florian Müllner 2013-05-27 10:20:26 EDT
May 13 17:29:32 localhost /etc/gdm/Xsession[992]: Bluetooth:ERROR:rfkill-glib.c:83:type_to_string: code should not be reached
May 13 17:29:32 localhost abrt[1490]: statvfs('/var/tmp/abrt'): No such file or directory
May 13 17:29:32 localhost /etc/gdm/Xsession[992]: gnome-session[992]: WARNING: Application 'gnome-shell.desktop' killed by signal 6


Ah, that's a known issue with gnome-bluetooth and newer kernels, see https://git.gnome.org/browse/gnome-bluetooth/commit/?h=gnome-3-8&id=9932a6316be777d4.

That is from the first log, it's not quite clear whether the problem is the same on the installed system.
Comment 5 FireWave 2013-05-29 12:47:37 EDT
I confirm I've got the same issue. On LiveCD and after installation. Same localhost /etc/gdm/Xsession[992]: Bluetooth:ERROR:rfkill-lib.c:83:type_to_string: code should not be reached.
Comment 6 Fedora Update System 2013-06-03 10:04:50 EDT
gnome-bluetooth-3.8.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-bluetooth-3.8.1-1.fc19
Comment 7 Fedora Update System 2013-06-04 22:33:59 EDT
Package gnome-bluetooth-3.8.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-bluetooth-3.8.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10044/gnome-bluetooth-3.8.1-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-05 22:27:08 EDT
gnome-bluetooth-3.8.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.