Bug 962569 - create new VM fails with error argument of type 'bool' is not iterable
Summary: create new VM fails with error argument of type 'bool' is not iterable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F19Beta-accepted, F19BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-13 21:43 UTC by Chris Murphy
Modified: 2013-06-01 03:27 UTC (History)
10 users (show)

Fixed In Version: virt-manager-0.10.0-0.5.gitde1695b2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-19 19:51:40 UTC
Type: Bug


Attachments (Terms of Use)
GUI dialog details shows this (546 bytes, text/plain)
2013-05-13 21:43 UTC, Chris Murphy
no flags Details
Output from virt-manager --debug (8.77 KB, text/plain)
2013-05-13 21:44 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2013-05-13 21:43:21 UTC
Description of problem:
When creating a new VM, I receive an error message "Uncaught error validating install parameters: argument of type 'bool' is not iterable".

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-0.2.gitb68faac8.fc19.noarch



How reproducible:
Always

Steps to Reproduce:
1. Install from Fedora-Live-Desktop-x86_64-19-Beta-TC4-1.iso using Installation Options > Partition Scheme BTRFS into free space on bare metal. Otherwise defaults.
2. yum update
3. reboot
4. yum groupinstall virtualization
5. yum install avahi-tools
6. Launch Virtual Machine Manager and authenticate.
7. Click on button "create new virtual machine": name=hello, Local install media selected, click forward.
8. Choose "Use ISO image", then click Browse, find the install ISO in /home/chris/Downloads. Click Forward.
  
Actual results:
Error message appears:
Uncaught error validating install parameters: argument of type 'bool' is not iterable

Expected results:
Successfully proceed to step 3 of 5 in the wizard.

Additional info:

Comment 1 Chris Murphy 2013-05-13 21:43:57 UTC
Created attachment 747452 [details]
GUI dialog details shows this

Comment 2 Chris Murphy 2013-05-13 21:44:53 UTC
Created attachment 747453 [details]
Output from virt-manager --debug

Comment 3 Robert Lightfoot 2013-05-15 09:04:10 UTC
ALso jsut saw this bug when working from http repo install without any install media.

Comment 4 Robert Lightfoot 2013-05-15 09:08:20 UTC
Proposing as Beta Blocker due to Self Hosting Virtualization Requirement -- "The release must be able host virtual guest instances of the same release. "

Comment 5 Adam Williamson 2013-05-15 15:26:28 UTC
+1 blocker.

Comment 6 Tim Flink 2013-05-15 19:14:44 UTC
I just hit this on a fresh install of F19 TC4 (standard partitions, autopart, single disk). Updated post-install and installed virt-manager. Got the error shown in the debug output attached in c#2

Comment 7 Fedora Update System 2013-05-15 20:10:57 UTC
virt-manager-0.10.0-0.3.gitb68faac8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-0.3.gitb68faac8.fc19

Comment 8 Tim Flink 2013-05-15 20:39:34 UTC
update from c#7 fixes the issue for me

Comment 9 Adam Williamson 2013-05-15 23:29:27 UTC
Discussed at 2013-05-15 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Rejected as a blocker on the basis that there are various workarounds to get VMs working (use Boxes or virt-install), but accepted as a freeze exception issue.

Comment 10 Adam Williamson 2013-05-19 19:51:40 UTC
0.4.git was pushed stable; closing.

Comment 11 Fedora Update System 2013-05-27 23:42:28 UTC
virt-manager-0.10.0-0.5.gitde1695b2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-0.5.gitde1695b2.fc19

Comment 12 Fedora Update System 2013-06-01 03:27:27 UTC
virt-manager-0.10.0-0.5.gitde1695b2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.