Bug 962572 - X-sandboxes are not resizeable
X-sandboxes are not resizeable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 962636
  Show dependency treegraph
 
Reported: 2013-05-13 18:43 EDT by Peter Hutterer
Modified: 2013-05-24 16:19 EDT (History)
9 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.14.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 915202
: 962636 (view as bug list)
Environment:
Last Closed: 2013-05-24 16:19:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2013-05-13 18:43:47 EDT
+++ This bug was initially created as a clone of Bug #915202 +++

Description of problem:
Since update to RHEL6.4 GUI sandboxes (`sandbox -X`) are not resizeable.
This used to work perfectly on RHEL6.3.

Version-Release number of selected component (if applicable):
policycoreutils-2.0.83-19.30.el6.x86_64
xorg-x11-server-Xephyr-1.13.0-11.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. sandbox -X firefox
2. try resizing sandbox
  
Actual results:
Sandbox can not be resized

Expected results:
Sandbox can be resized

--- Additional comment from Daniel Walsh on 2013-02-26 16:41:42 EST ---

Did the Xephyr Resize patch get removed?

--- Additional comment from Marian Csontos on 2013-02-27 04:06:58 EST ---

Short answer is yes, it got. Commit 1dee54d04.

Among other things this really breaks things in tiling window managers.
Also saved firefox sessions from RHEL6.3 are broken: firefox is using larger window than Xephyr.

Would it be possible getting it back in z-stream?

--- Additional comment from Marian Csontos on 2013-02-27 04:26:07 EST ---

And the workaround for broken firefox session is to search for /"width":/ and /"height":/ in profile's sessionstore.js (~/.mozilla/firefox/s0m3jVnK.default/sessionstore.js) and hand edit the numbers.

--- Additional comment from Peter Hutterer on 2013-05-12 23:52:04 EDT ---

Patch was removed from RHEL server because it got merged upstream as xorg-server-1.12.99.903-3-g8843aed. However, the upstream patch has two hunks different than the one we used to ship. Specifically, the resize option is now only enabled if win_pre_existing is != None whereas the previous patch had this unconditionally.

Best option here is probably to cherry-pick "ephyr: Add -resizeable option" (xorg-server-1.13.99.902-23-g3aac7a5) and set EphyrWantResize to 1 by default. This should emulate the behaviour of RHEL 6.3.

--- Additional comment from Daniel Walsh on 2013-05-13 12:53:26 EDT ---

Can we get the same option turned on in Fedora also?
Comment 1 Fedora Update System 2013-05-14 02:45:31 EDT
xorg-x11-server-1.14.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.14.1-2.fc19
Comment 2 Fedora Update System 2013-05-14 13:47:57 EDT
Package xorg-x11-server-1.14.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.14.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8173/xorg-x11-server-1.14.1-2.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-05-24 16:19:49 EDT
xorg-x11-server-1.14.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.