Bug 962623 - core:peer probe says failed in .cmd_log_history though it passes
core:peer probe says failed in .cmd_log_history though it passes
Status: CLOSED DUPLICATE of bug 958199
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 01:05 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 07:00:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-05-14 01:05:50 EDT
Description of problem:
tried to peer probe the server
the .cmd_log_history reports it is failure
though it has passed.

[root@bigbend1 ~]# gluster peer status
Number of Peers: 3

Hostname: 10.70.37.100
Port: 24007
Uuid: 5aa707d1-08eb-4bcc-bce4-f559fede4f15
State: Peer in Cluster (Connected)

Hostname: 10.70.37.121
Port: 24007
Uuid: a347af2c-2671-49e9-89d4-c2c59304d73b
State: Peer in Cluster (Connected)

Hostname: 10.70.37.211
Port: 24007
Uuid: b251e1a4-de96-4823-9c9f-9c4f7bb5b8f4
State: Peer in Cluster (Connected)

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.7rhs-1.el6rhs.x86_64

How reproducible:
found on latest bits of glusterfs 3.4.0-7

Steps to Reproduce:
1. remove older rpms on all nodes
2. rm -rf /var/lib/glusterd on all nodes
3. rm -rf all bricks on all nodes
4. install new rpms
5. gluster peer probe

  
Actual results:
gluster peer status shows they are Connected,
.cmd_log_history shows probe as FAILED.

showing the last part of the logs,

[2013-05-13 22:06:59.224410] peer probe :  on host 10.70.37.100:24007
[2013-05-13 22:06:59.251216] peer probe : on host 10.70.37.100:24007 FAILED
[2013-05-13 22:07:02.737870] peer probe :  on host 10.70.37.121:24007
[2013-05-13 22:07:02.751561] peer probe : on host 10.70.37.121:24007 FAILED
[2013-05-13 22:07:05.637105] peer probe :  on host 10.70.37.211:24007
[2013-05-13 22:07:05.652064] peer probe : on host 10.70.37.211:24007 FAILED
[2013-05-13 22:07:41.003402]  : volume create dist-rep replica 2 10.70.37.155:/rhs/brick1/d1r1 10.70.37.100:/rhs/brick1/d1r2 10.70.37.121:/rhs/brick1/d2r1 10.70.37.211:/rhs/brick1/d2r2 10.70.37.155:/rhs/brick1/d3r1 10.70.37.100:/rhs/brick1/d3r2 10.70.37.121:/rhs/brick1/d4r1 10.70.37.211:/rhs/brick1/d4r2 10.70.37.155:/rhs/brick1/d5r1 10.70.37.100:/rhs/brick1/d5r2 10.70.37.121:/rhs/brick1/d6r1 10.70.37.211:/rhs/brick1/d6r2 : SUCCESS
[2013-05-13 22:08:00.447056]  : volume start dist-rep : SUCCESS


Expected results:
.cmd_log_history should show the actual result.

Additional info:
Comment 4 Krutika Dhananjay 2013-07-11 07:00:18 EDT

*** This bug has been marked as a duplicate of bug 958199 ***

Note You need to log in before you can comment on or make changes to this bug.