Bug 962676 - hsqldb has a hard depend on a version of java which is unavailable on some platforms
hsqldb has a hard depend on a version of java which is unavailable on some pl...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hsqldb (Show other bugs)
6.5
Unspecified Unspecified
high Severity urgent
: rc
: 6.5
Assigned To: Mikolaj Izdebski
Filip Holec
: Regression
Depends On:
Blocks: 919230
  Show dependency treegraph
 
Reported: 2013-05-14 04:43 EDT by Caolan McNamara
Modified: 2016-04-18 06:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.8.0.10-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:16:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2013-05-14 04:43:14 EDT
Description of problem:
RHEL-6 hsqldb has a hard depend on a version of java which is unavailable on some RHEL-6 platforms in  s390/s390x etc

Version-Release number of selected component (if applicable):
1:hsqldb-1.8.0.10-10.el6

How reproducible:
100%

Steps to Reproduce:
1. on s390, s390x (and ppc + ppc64 I think) try and build something that depends on hsqldb.
  
Actual results:
DEBUG util.py:256:  Package binutils-2.20.51.0.2-5.36.el6.s390x already installed and latest version
DEBUG util.py:256:  1:hsqldb-1.8.0.10-10.el6.noarch from build has depsolving problems
DEBUG util.py:256:    --> Missing Dependency: java >= 1:1.6.0 is needed by package 1:hsqldb-1.8.0.10-10.el6.noarch (build)
DEBUG util.py:256:  Error: Missing Dependency: java >= 1:1.6.0 is needed by package 1:hsqldb-1.8.0.10-10.el6.noarch (build)
DEBUG util.py:256:   You could try using --skip-broken to work around the problem
DEBUG util.py:256:   You could try running: package-cleanup --problems
DEBUG util.py:256:                          package-cleanup --dupes
DEBUG util.py:256:                          rpm -Va --nofiles --nodigest
DEBUG util.py:256:  The program package-cleanup is found in the yum-utils package.
DEBUG util.py:319:  Child returncode was: 1

Additional info:
So I can't rebuild libreoffice for RHEL-6 without hacking it
Comment 13 Mikolaj Izdebski 2013-07-03 02:45:19 EDT
Fixed in hsqldb-1.8.0.10-11
Comment 17 errata-xmlrpc 2013-11-21 06:16:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1614.html

Note You need to log in before you can comment on or make changes to this bug.