Bug 962681 - Button for deleting data provider does not work - no explanation is given to the user
Button for deleting data provider does not work - no explanation is given to ...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity high
: DR6
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 05:00 EDT by Jan Hrcek
Modified: 2014-08-06 16:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Message not shown due to a javascript syntax error. Consequence: No feedback given to the user. Fix: Format the warning message properly. Result: Message shown to the user.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Application log after "delete" button is clicked (25.60 KB, text/x-log)
2013-05-14 05:00 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-05-14 05:00:19 EDT
Created attachment 747563 [details]
Application log after "delete" button is clicked

Description of problem:
When a button for deleting some data provider is clicked, nothing happens.
It seems that this is caused by the data provider being used in some KPI Panels - but the problem is that no indication is given to the user why the provider was not deleted.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Workspace "Showcase", page "Data providers"
2. Click the button "Delete Data Provider" next to some of the out-of-the box data providers, for example "Sales dashboard demo".
  
Actual results:
Page reloads, but nothing else happens - provider is not deleted, it is left in place.

Expected results:
When user tries to delete a data provider, that cannot be deleted (e.g. because it's used in some KPI panels) some message should be displayed indicating why it is not possible to delete that provider (e.g. "It is impossible to delete this data provider, because it is used in 5 panels" or "Cannot delete data provider X, because it is used by 5 panels" or something similar).

Additional information:
When the delete button is clicked, the following error appears in the application log (see the attachment)
Comment 1 David Gutierrez 2013-06-12 05:35:40 EDT
The error has been fixed. Now, a message like this is shown "Cannot delete the data provider because it is used by 5 KPI(s)"

Github commit: https://github.com/droolsjbpm/dashboard-builder/commit/cd1e7fb50d835af4da806cf3b21b59bf099ab3ab
Comment 2 Jan Hrcek 2013-07-13 03:09:33 EDT
Ok, verified with BPMS 6.0.0.DR6 deployed on EAP 6.1

Note You need to log in before you can comment on or make changes to this bug.