Bug 962685 - AttributeError: 'NoneType' object has no attribute 'split'
AttributeError: 'NoneType' object has no attribute 'split'
Status: CLOSED DUPLICATE of bug 959710
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e589c402a8288468842f5ff695f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 05:13 EDT by Petr Schindler
Modified: 2013-05-20 20:21 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 20:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (770.37 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: anaconda.log (11.72 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: backtrace (897 bytes, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: environ (758 bytes, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: ifcfg.log (656 bytes, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: lsblk_output (2.03 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: nmcli_dev_list (3.79 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: packaging.log (284.78 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: program.log (34.77 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: storage.log (154.39 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details
File: syslog (135.57 KB, text/plain)
2013-05-14 05:14 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2013-05-14 05:13:57 EDT
Description of problem:
Right after I selected a language to use, anaconda showed window with network setting. 

I have turned on network (wired). 

On the main window of anaconda there was something like 'unset installation source' (I used netinst.iso). 

I clicked on Installation source and on 'done'. 

Installation source was set up now but no 'software collection' was chosen. 

When I clicked on 'Software selection' the anaconda froze and traceback was shown.
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
AttributeError: 'NoneType' object has no attribute 'split'

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
AttributeError: 'NoneType' object has no attribute 'split'
Comment 1 Petr Schindler 2013-05-14 05:14:03 EDT
Created attachment 747570 [details]
File: anaconda-tb
Comment 2 Petr Schindler 2013-05-14 05:14:08 EDT
Created attachment 747571 [details]
File: anaconda.log
Comment 3 Petr Schindler 2013-05-14 05:14:11 EDT
Created attachment 747572 [details]
File: backtrace
Comment 4 Petr Schindler 2013-05-14 05:14:13 EDT
Created attachment 747573 [details]
File: environ
Comment 5 Petr Schindler 2013-05-14 05:14:15 EDT
Created attachment 747574 [details]
File: ifcfg.log
Comment 6 Petr Schindler 2013-05-14 05:14:17 EDT
Created attachment 747575 [details]
File: lsblk_output
Comment 7 Petr Schindler 2013-05-14 05:14:19 EDT
Created attachment 747576 [details]
File: nmcli_dev_list
Comment 8 Petr Schindler 2013-05-14 05:14:22 EDT
Created attachment 747577 [details]
File: packaging.log
Comment 9 Petr Schindler 2013-05-14 05:14:28 EDT
Created attachment 747578 [details]
File: program.log
Comment 10 Petr Schindler 2013-05-14 05:14:37 EDT
Created attachment 747579 [details]
File: storage.log
Comment 11 Petr Schindler 2013-05-14 05:14:42 EDT
Created attachment 747580 [details]
File: syslog
Comment 12 Petr Schindler 2013-05-14 07:47:53 EDT
After I boot there is 'Error setting up software source'
Comment 13 Jens Petersen 2013-05-17 03:11:16 EDT
Happened again with Beta RC2 when I went to the env spoke.
Comment 14 Jan Sedlák 2013-05-17 07:31:38 EDT
Confirming, this bug is still present in Beta RC2.
Comment 15 Mukundan Ragavan 2013-05-19 16:02:45 EDT
Description of problem:
Anaconda crashes when trying to select a package group.

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 353, in on_environment_selection_changed
    self.on_environment_toggled(None, model.get_path(itr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 337, in on_environment_toggled
    for groupid in self.payload.environmentGroups(self.environment):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1084, in environmentGroups
    if not groups.has_environment(environmentid):
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 650, in has_environment
    exists = self.return_environments(environmentid)
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 669, in return_environments
    for item in env_pattern.split(','):
AttributeError: 'NoneType' object has no attribute 'split'
Comment 16 Adam Williamson 2013-05-20 19:55:56 EDT
Does someone have a reliable reproducer for this? Brian thinks it looks like it only happens when there is a network or repo problem of some kind.
Comment 17 Adam Williamson 2013-05-20 20:21:01 EDT

*** This bug has been marked as a duplicate of bug 959710 ***

Note You need to log in before you can comment on or make changes to this bug.