Bug 962702 - The RPM package and ldconfig disagree on where soft link should point
The RPM package and ldconfig disagree on where soft link should point
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 05:44 EDT by Göran Uddeborg
Modified: 2015-02-18 08:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 08:53:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2013-05-14 05:44:39 EDT
Description of problem:
The link /usr/lib64/libSDL-1.2.so.0 should point to libSDL-1.2.so.0.11.4 according to the RPM package SDL.  But immediately after installation of SDL and SDL-devel, it points to libSDL.so.  Presumably, the ldconfig run in the postinstall is responsible for the modification.


Version-Release number of selected component (if applicable):
SDL-1.2.15-7.fc19.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. Install/upgrade SDL.x86_64 and SDL-devel.x86_&4
2. rpm -V SDL


Actual results:
....L....    /usr/lib64/libSDL-1.2.so.0


Expected results:
No output.
Comment 1 Petr Pisar 2013-06-19 05:15:07 EDT
I'm sorry I cannot reproduce your problem with SDL-1.2.15-8.fc19.x86_64. The symlinks in the RPM packages are good, the scriptlets in both packages too, and running ldconfig or ldconfig -i does not introduce any change.

Does you problem still persist?
Comment 2 Göran Uddeborg 2013-06-29 16:44:55 EDT
Sorry for the delay.  I've been out travelling and not had the opportunity to try until now.

But now I tried to upgrade to the latest SDL (9.fc19), and the problem was indeed not there after the upgrade.  libSDL-1.2.so.0 points to libSDL-1.2.so.0.11.4 as expected.

There is still something weird going on that I don't understand though.  ldconfig still prefers to link libSDL-1.2.so.0 to libSDL.so.  It says so if I run "ldconfig -v", and if I remove the link libSDL-1.2.so.0 and reruns ldconfig, it creates a link pointing to libSDL.so rather than libSDL-1.2.so.0.11.4.

But if the libSDL-1.2.so.0 link is there, and points to libSDL-1.2.so.0.11.4 before ldconfig is run, then it is left in place.  Possibly what happened when I upgraded to 7.fc19 was that the link was removed, and then ldconfig created the new incorrect link.  I don't understand what would cause that, though.  And I don't understand why ldconfig wants to point to libSDL.so rather than libSDL-1.2.so.0.11.4 in the first place.
Comment 3 Petr Pisar 2013-07-01 05:36:35 EDT
I think it's because libSDL.so symlink is called libSDL.so and not libSDL-1.2.so to mach the base name. If you uninstall SDL-devel or if you remove the libSDL.so symlink, then ldconfig will show expected values.

I think the symlink for compile-time linking should be called libSDL-1.2.so. But I worry there is a strong compatibility reason because the bad name is used everywhere (other distributions, upstream). I worry that removing the bad name could cause someone's headaches.

The same issue is with libSDL_ttf.so.

I will ask on fedora-devel.
Comment 4 Göran Uddeborg 2013-07-03 14:15:51 EDT
Thanks.  I see your message, and will follow and see if you get any replies.
Comment 5 Petr Pisar 2013-07-04 10:38:22 EDT
The thread is <http://thread.gmane.org/gmane.linux.redhat.fedora.devel/181593>.

No explanation has been provided so far. A back-ward compatibility tip was to use proper base name and create a linker script under the libSDL.so name.
Comment 6 Fedora End Of Life 2015-01-09 17:07:04 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2015-02-18 08:53:49 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.