Bug 962706 - Add various important fixes (mostly related to lvmetad and thin provisioning) to F19
Add various important fixes (mostly related to lvmetad and thin provisioning)...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
19
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Rajnoha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 06:00 EDT by Peter Rajnoha
Modified: 2013-05-24 16:38 EDT (History)
12 users (show)

See Also:
Fixed In Version: lvm2-2.02.98-9.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:38:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Rajnoha 2013-05-14 06:00:21 EDT
Add following fixes to F19 lvm2 build. These are mostly related to lvmetad (which is used by default in F19 now) and thin provisioning functionality in lvm2:

- Fix a crash-inducing race condition in lvmetad while updating metadata.
- Fix possible race while removing metadata from lvmetad.
- Fix possible deadlock when querying and updating lvmetad at the same time.
- Avoid a global lock in pvs when lvmetad is in use. 
- Fix crash in pvscan --cache -aay triggered by non-mda PV.
- Fix lvm2app to return all property sizes in bytes.
- Add lvm.conf option global/thin_disabled_features.
- Add lvconvert support to swap thin pool metadata volume.
- Implement internal function detach_pool_metadata_lv().
- Fix lvm2app and return lvseg discards property as string.
- Allow forced vgcfgrestore of lvm2 metadata with thin volumes.
- Add lvm.conf thin pool defs thin_pool_{chunk_size|discards|zero}.
- Support discards for non-power-of-2 thin pool chunks.
- Support allocation of pool metadata with lvconvert command.
- Move common functionality for thin lvcreate and lvconvert to toollib.
- Use lv_is_active() instead of lv_info() call.

Also add these additional fixes for proper functinality:

- Fix 'dmsetup splitname -o' to not fail if used without '-c' switch (1.02.68).
- Close open dmeventd FIFO file descriptors on exec (FD_CLOEXEC).
- Fix premature DM version checking which caused useless mapper/control access.
- Recognize DM_DISABLE_UDEV environment variable for a complete fallback.
- Do not verify udev operations if --noudevsync command option is used.
- Fix blkdeactivate to handle nested mountpoints and mangled mount paths.
Comment 1 Fedora Update System 2013-05-14 07:31:55 EDT
lvm2-2.02.98-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lvm2-2.02.98-9.fc19
Comment 2 Jonathan Earl Brassow 2013-05-15 17:14:50 EDT
Any chance we could include switching the defaults for 'mirror_segtype_default' and 'raid10_segtype_default' to "raid1" and "raid10" respectively to that list?

They were to be included by default due to an upstream LVM release, but I don't think that's happened yet.
Comment 3 Mike Snitzer 2013-05-15 17:33:59 EDT
Would also like to see this included:
- Fix alignment of PV data area if detected alignment less than 1 MB (2.02.74).
Comment 4 Peter Rajnoha 2013-05-16 03:25:59 EDT
Well, I believe there's going to be one more build once we have upstream release ready.

But for now, I just wanted one build quickly for F19 beta with urgent lvmetad fixes (lvmetad is used by default there) and other things necessary (the patches are actually from 6.4 which already undergone QA) + a few ones for which there were existing bug reports open for F19...
Comment 5 Fedora Update System 2013-05-24 16:38:09 EDT
lvm2-2.02.98-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.