Bug 962799 - CVE-2013-2094 kernel: perf_swevent_enabled array out-of-bound access [fedora-all]
CVE-2013-2094 kernel: perf_swevent_enabled array out-of-bound access [fedora-...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Security, SecurityTracking
Depends On:
Blocks: CVE-2013-2094
  Show dependency treegraph
 
Reported: 2013-05-14 09:05 EDT by Petr Matousek
Modified: 2013-05-20 07:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 09:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2013-05-14 09:05:27 EDT
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

Please note: this issue affects multiple supported versions of Fedora.
Only one tracking bug has been filed; please ensure that it is only closed
when all affected versions are fixed.

Reproducers, if any, will remain confidential and never be made public, unless done so by the security team.

[bug automatically created by: add-tracking-bugs]
Comment 1 Petr Matousek 2013-05-14 09:05:41 EDT
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=962792,962799
Comment 2 Josh Boyer 2013-05-14 09:54:43 EDT
This is fixed in 3.9-rc8.  Rawhide, F19, and F18 are already on 3.9.  The commit was backported to 3.8.9 with stable commit ff91fd5bc105f29a34755a6dd6d547c877b7d027.  F17 is already on 3.8.13.

Already fixed.
Comment 3 Konstantin Ryabitsev 2013-05-14 10:22:54 EDT
F18 is not on 3.9 -- the latest available kernel in F18 is 3.8.11.
Comment 4 Josh Boyer 2013-05-14 10:33:29 EDT
(In reply to comment #3)
> F18 is not on 3.9 -- the latest available kernel in F18 is 3.8.11.

Oops, yes.  Sorry, was speaking from a "in the git repository" perspective.  3.9.2 is pending in updates-testing for F18.  3.8.11 still contains the same fix mentioned for F17, so the bug is still fixed.

Note You need to log in before you can comment on or make changes to this bug.