Bug 9628 - bug in time zone selection
bug in time zone selection
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-21 04:50 EST by David Balažic
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 12:40:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2000-02-21 04:50:16 EST
text mode install from CD
When selecting the time zone the time displayed is wrong.
What happened:
 - the time zone screen appears
 - is scroll up to item 'Europe/Ljubljana', which is my timezone and I have
HW clock set to local time
 - the time displayed is 1h in future
 - I select the 'HW clock set to GMT' option
 - time displayed still 1h in future ( but this time this is correct )
 - I deselect the 'HW clock set to GMT' option
 - and finally the correct time is displayed
Comment 1 Jay Turner 2000-02-22 16:03:59 EST
This issue is resolved by the latest cut of the beta installer.
Comment 2 David Balažic 2000-04-03 11:43:59 EDT
X This issue is reopened by releasing RH6.2(zoot) X

The only difference is that after selecting my timezone ( Europe/Ljubljana ),
the time is off by several hours (IIRC) , selecting "clock-is-GMT" and then
deselecting it fixes the problem.
Comment 3 David Balažic 2000-04-10 09:14:59 EDT
Hello , is anyone out there ?
Comment 4 Jay Turner 2000-04-12 07:40:59 EDT
Able to recreate this in the lab.  With hardware clock set to local time
(8:00am) I changed to the 'Europe/Ljubljana' timezone and the clock in the Time
Zone Selection screen showed something like 15:00.  Clicking "Set clock to GMT"
changed the time to 10:00am, and then unchecking the box changed the time to
8:00am.  So, definitely something weird happening here.
Comment 5 Pekka Savola 2000-05-11 07:09:59 EDT
The same happens here too.  I scan the list up with PGUP key and then a couple
of times PGDN and a few corrections, and I'll get to Europe/Helsinki.

Time displayed is definitely not either GMT or non-GMT time here, not even
close.

*THIS IS SERIOUS* because modules fail to load if time is set in the future
(files are created with future timestamps, rebooting restores machine's old time
from hardware clock).  They have to be loaded manually because timestamps are
wrong.  Using 'touch' on /etc/conf.modules and
/lib/modules/2.2.14-12/modules.dep helps a mite.
Comment 6 Pekka Savola 2000-05-25 11:02:59 EDT
Ok, here's how this can be circumvented when installing:

Check 'use GMT' checkbox, and then uncheck it.

HOWEVER, using this seems to break installer in different ways -- it doesn't
write alias for network interfaces in /etc/conf.modules as it normally does if
this workaround is used.

VERY weird, and also SERIOUS. :(
Comment 7 David Balažic 2000-06-19 13:03:40 EDT
I think this also happens with winston (beta1), but I can't check right now. It 
is trivial to check, so please someone at RH do it.
Comment 8 David Balažic 2000-06-19 13:04:49 EDT
The relevant bug entry for beta1 might be #12155.
Comment 9 Michael Fulbright 2000-06-22 12:40:42 EDT
Should be addressed in internal development build.

Note You need to log in before you can comment on or make changes to this bug.