Bug 962828 - GloballyUncaughtException when changing a parameter in Connection Settings tab of a compatible group after a plugin update
GloballyUncaughtException when changing a parameter in Connection Settings ta...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.2
Unspecified Unspecified
high Severity high
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On: 962787
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 10:20 EDT by Thomas Segismont
Modified: 2014-01-02 15:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962787
Environment:
Last Closed: 2014-01-02 15:35:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated and saved value for property errorMessage_0. (169.32 KB, image/png)
2013-10-16 12:40 EDT, jvlasak
no flags Details
After saving the value of property Error Message_ 1 for group, the same value was updated for the property of group resource. No exception was thrown. (297.20 KB, image/png)
2013-10-24 09:13 EDT, jvlasak
no flags Details

  None (edit)
Description Thomas Segismont 2013-05-14 10:20:32 EDT
+++ This bug was initially created as a clone of Bug #962787 +++

Description of problem:
The server show a GloballyUncaughtException when changing a parameter in Connection Settings tab of a compatible group after a plugin update. This only applies to new plugin-config properties introduced in existing resources after a plugin update.


Version-Release number of selected component (if applicable):
4.7

How reproducible:
Always

Steps to Reproduce:
1.Choose a resource in inventory
2.Add a new plugin-config property in the plugin descriptor file for the type of this resource
3.Rebuild the plugin and upload it
4.Go to the Connection Settings tab of the resource view and check the new parameter is present
5.Create (if needed) a compatible group for this resource
6.Change the new parameter value
  
Actual results:
The server shows a GloballyUncaughtException message and the Save button is disabled.

Expected results:
The Save button is enabled and after clicking on save, the value is updated for all members of the group.

Additional info:
I also noticed that the plugin-config property defaults are not correctly set for existing resources.
It should also be checked if resource-configuration properties have the same problem.

--- Additional comment from Thomas Segismont on 2013-05-14 14:57:58 CEST ---

From the messages box in RHQ server

com.google.gwt.event.shared.UmbrellaException:2 exceptions caught: (TypeError) : Cannot set property 'errorMessage_0' of undefined; (TypeError) : Cannot set property 'stringValue' of undefined
   com.google.gwt.core.client.JavaScriptException:(TypeError) : Cannot set property 'errorMessage_0' of undefined
--- STACK TRACE FOLLOWS ---
2 exceptions caught: (TypeError) : Cannot set property 'errorMessage_0' of undefined; (TypeError) : Cannot set property 'stringValue' of undefined
   at Unknown.createStackTrace(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@63)
   at Unknown.fillInStackTrace_1(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@11)
   at Unknown.fillInStackTrace(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@56)
   at Unknown.$fillInStackTrace(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@3)
   at Unknown.$$init_0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@3)
   at Unknown.Throwable_2(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@3)
   at Unknown.Exception_2(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@15)
   at Unknown.RuntimeException_2(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@15)
   at Unknown.UmbrellaException_2(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@22)
   at Unknown.UmbrellaException_4(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@23)
   at Unknown.$fireEvent(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@13)
   at Unknown.fireEvent_4(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@30)
   at Unknown.<anonymous>(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@11)
   at Unknown.apply(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@23)
   at Unknown.entry0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@16)
   at Unknown.changed(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@14)
   at Unknown.isc_FormItem_handleChanged(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@22)
   at Unknown.isc_FormItem_storeValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@186)
   at Unknown.isc_FormItem__updateValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@43)
   at Unknown.isc_FormItem_updateValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@156)
   at Unknown.isc_FormItem__handleInput(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@170)
   at Unknown.oninput(http://localhost:7080/coregui/#ResourceGroup/10001/Inventory/ConnectionSettings@102)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot set property 'errorMessage_0' of undefined
   at Unknown.$setErrorMessage_0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@84)
   at Unknown.updatePropertySimpleValue_0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@9)
   at Unknown.onChanged_32(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@15)
   at Unknown.$dispatch_26(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@11)
   at Unknown.dispatch_27(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@3)
   at Unknown.dispatch(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@8)
   at Unknown.dispatchEvent_0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@11)
   at Unknown.$doFire(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@9)
   at Unknown.$fireEvent_0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@3)
   at Unknown.$fireEvent(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@5)
   at Unknown.fireEvent_4(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@30)
   at Unknown.<anonymous>(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@11)
   at Unknown.apply(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@23)
   at Unknown.entry0(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@16)
   at Unknown.changed(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D98AE5C30524A711A8F7D371EDF979A3.cache.html@14)
   at Unknown.isc_FormItem_handleChanged(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@22)
   at Unknown.isc_FormItem_storeValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@186)
   at Unknown.isc_FormItem__updateValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@43)
   at Unknown.isc_FormItem_updateValue(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@156)
   at Unknown.isc_FormItem__handleInput(http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Forms.js@170)
   at Unknown.oninput(http://localhost:7080/coregui/#ResourceGroup/10001/Inventory/ConnectionSettings@102)

--- Additional comment from Thomas Segismont on 2013-05-14 16:19:38 CEST ---

It should be checked if group update works from the CLI. It might be a GUI caching issue.
Comment 1 Thomas Segismont 2013-05-16 08:31:27 EDT
Fixed in master

commit f9052819e3da19359081274d62eb6b0f75dd63e2
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu May 16 14:28:01 2013 +0200

    Bug 962787 - GloballyUncaughtException when changing a parameter in Connection Settings tab of a compatible group after a plugin update
Comment 2 Larry O'Leary 2013-09-06 10:31:36 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 3 jvlasak 2013-10-16 12:40:13 EDT
Created attachment 813060 [details]
Updated and saved value for property errorMessage_0.

Done basic test for plugin-config property:

<c:simple-property name="errorMessage_0" type="string" required="false" description="Testing property" />

with correct result (see screenshot).

Further investigation for additional info is necessary.
Comment 4 Thomas Segismont 2013-10-16 12:54:28 EDT
(In reply to jvlasak from comment #3)
> Created attachment 813060 [details]
> Updated and saved value for property errorMessage_0.
> 
> Done basic test for plugin-config property:
> 
> <c:simple-property name="errorMessage_0" type="string" required="false"
> description="Testing property" />
> 
> with correct result (see screenshot).

Your screenshot does not show a compatible group but an individual resource. Did you test the resource group problem?

> Further investigation for additional info is necessary.

Which comment are you talking about?
Comment 5 jvlasak 2013-10-24 08:47:39 EDT
Result of my communication with Thomas Segismont to his questions:

1) CLI test: Don't need to be checked, this was a pure GUI bug.
2) Additional info: This refers to resource configuration tab, but at that time I did not know it uses the same code, so if it's fixed in connection settings tab, it's fixed in resource config tab.

Result was the way how test this:
You should not see any error when saving changes on the group config editor view and then you should see changes applied in each resource of the group (in your particular case, just one resource).
Comment 6 jvlasak 2013-10-24 09:13:34 EDT
Created attachment 815779 [details]
After saving the value of property Error Message_ 1 for group, the same value was updated for the property of group resource. No exception was thrown.

Verified according to the testing guideline above.

Note You need to log in before you can comment on or make changes to this bug.