Bug 962865 - IOError: iface iter could not read dir /var/lib/iscsi/nodes/iqn.2009-02.net.tirfa.:for.all/192.168.0.5,3260,1.
IOError: iface iter could not read dir /var/lib/iscsi/nodes/iqn.2009-02.net.t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:8bfc618171799a3de0fcd43fc21...
:
: 960610 (view as bug list)
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-14 11:41 EDT by Tim Flink
Modified: 2013-05-21 13:11 EDT (History)
15 users (show)

See Also:
Fixed In Version: python-blivet-0.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-19 15:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (12.54 KB, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: backtrace (923 bytes, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: environ (760 bytes, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: lsblk_output (1.78 KB, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: nmcli_dev_list (3.47 KB, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: packaging.log (679.25 KB, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details
File: program.log (49.81 KB, text/plain)
2013-05-14 11:41 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2013-05-14 11:41:05 EDT
Description of problem:
I did a basic install in a VM using one vdisk and one iscsi LUN w/o auth
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 3693, in dracutSetupArgs
    auth = self.node.getAuth()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 806, in set_boot_args
    setup_args = dep.dracutSetupArgs()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2336, in writeBootLoader
    keyboard=ksdata.keyboard)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 148, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: iface iter could not read dir /var/lib/iscsi/nodes/iqn.2009-02.net.tirfa.:for.all/192.168.0.5,3260,1.

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 148, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2336, in writeBootLoader
    keyboard=ksdata.keyboard)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 806, in set_boot_args
    setup_args = dep.dracutSetupArgs()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 3693, in dracutSetupArgs
    auth = self.node.getAuth()
IOError: iface iter could not read dir /var/lib/iscsi/nodes/iqn.2009-02.net.tirfa.:for.all/192.168.0.5,3260,1.
Comment 1 Tim Flink 2013-05-14 11:41:08 EDT
Created attachment 747736 [details]
File: anaconda.log
Comment 2 Tim Flink 2013-05-14 11:41:09 EDT
Created attachment 747737 [details]
File: backtrace
Comment 3 Tim Flink 2013-05-14 11:41:11 EDT
Created attachment 747738 [details]
File: environ
Comment 4 Tim Flink 2013-05-14 11:41:12 EDT
Created attachment 747739 [details]
File: ifcfg.log
Comment 5 Tim Flink 2013-05-14 11:41:14 EDT
Created attachment 747740 [details]
File: lsblk_output
Comment 6 Tim Flink 2013-05-14 11:41:17 EDT
Created attachment 747741 [details]
File: nmcli_dev_list
Comment 7 Tim Flink 2013-05-14 11:41:20 EDT
Created attachment 747742 [details]
File: packaging.log
Comment 8 Tim Flink 2013-05-14 11:41:23 EDT
Created attachment 747743 [details]
File: program.log
Comment 9 Radek Vykydal 2013-05-15 09:26:43 EDT
We probably need to do

from . import ROOT_PATH

in iscsi.write() when ROOT_PATH is set to '/mnt/sysimage' by enable_installer_mode() rather then at the beginning of iscsi.py module
Comment 10 Radek Vykydal 2013-05-15 09:40:08 EDT
I'll pass this to Dave as he has better notion of how ROOT_PATH setting with enable_installer_mode() should work. Perhaps also other places (fcoe, dasd, ...) should be checked for the issue.
Comment 11 Radek Vykydal 2013-05-15 09:44:52 EDT
Err, Chris has already acked patch for it.
Comment 12 Fedora Blocker Bugs Application 2013-05-15 11:57:39 EDT
Proposed as a Freeze Exception for 19-beta by Fedora user tflink using the blocker tracking app because:

 This bug blocks installation using iSCSI targets without authentication which is a blocker for final. It would be useful to enable those installs now so that we can get test cases in order and make sure everything is working.
Comment 13 Chris Lumens 2013-05-15 12:57:46 EDT
Yeah, I got the blivet portion of it done but it appears there's another way to hit this if you go into custom partitioning instead of going through the reclaim dialog.  So, I guess there's some work to do in anaconda now.
Comment 14 Chris Lumens 2013-05-15 13:46:32 EDT
I was wrong, back to blivet.  But I'm sending off a patch too.
Comment 15 Adam Williamson 2013-05-15 19:37:14 EDT
Discussed at 2013-05-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Accepted as a freeze exception issue: this would be a final blocker, and obviously fixing it would improve our potential iSCSI test coverage with Beta.
Comment 16 David Cantrell 2013-05-16 08:25:59 EDT
*** Bug 960610 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2013-05-19 15:55:36 EDT
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19 was pushed stable, closing. But tflink, can you check this with RC2?
Comment 18 Tim Flink 2013-05-21 13:11:46 EDT
(In reply to Adam Williamson from comment #17)
> https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-
> 1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19 was pushed stable,
> closing. But tflink, can you check this with RC2?

Verified fix with F19 beta RC2.

Note You need to log in before you can comment on or make changes to this bug.