Bug 962911 - Unreachable link in error message
Unreachable link in error message
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 14:45 EDT by Sumana Annam
Modified: 2015-05-14 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumana Annam 2013-05-14 14:45:23 EDT
Description of problem:

Today, I experienced an error when attempting to restart my OpenShift app. The error message is listed in red.

$ rhc app restart pfpCore -l gpse.training+100@redhat.com -p jb0ssredhat

The server did not respond correctly. This may be an issue with the server configuration or with your connection to the server (such as a Web proxy or firewall).Please verify that you can access
the OpenShift server https://openshift.redhat.com/broker/rest/domains/gpsetraining100/applications/pfpCore/events

I just noticed this problem today. It worked fine for me last week. Also the URL mentioned in the error message does not exist (generates a 404).



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lili Nader 2013-05-14 23:51:29 EDT
Sumana, can you do a "rhc domain show" to see if your app exists?
Comment 2 Sumana Annam 2013-05-15 13:09:00 EDT
Yes it does exist! The above is from the user but I constructed the same for one of my apps:

https://openshift.redhat.com/broker/rest/domains/sannam/applications/phptest/events

dhcp-16-206:~ sumana$ rhc app show -a phptest
phptest @ http://phptest-sannam.rhcloud.com/ (uuid: 5128092a4382ec23790000fb)
-----------------------------------------------------------------------------
  Created: Feb 22  4:11 PM
  Gears:   1 (defaults to small)
  Git URL: ssh://5128092a4382ec23790000fb@phptest-sannam.rhcloud.com/~/git/phptest.git/
  SSH:     5128092a4382ec23790000fb@phptest-sannam.rhcloud.com

  php-5.3 (PHP 5.3)
  -----------------
    Gears: Located with mysql-5.1, phpmyadmin-3.4

  mysql-5.1 (MySQL Database 5.1)
  ------------------------------
    Gears:          Located with php-5.3, phpmyadmin-3.4
    Connection URL: mysql://127.4.139.1:3306/
    Database Name:  phptest
    Password:       ZY8AkCAQ_389
    Username:       adminyvDB6rP

  phpmyadmin-3.4 (phpMyAdmin 3.4)
  -------------------------------
    Gears:          Located with php-5.3, mysql-5.1
    Connection URL: https://phptest-sannam.rhcloud.com/phpmyadmin/
Comment 3 Abhishek Gupta 2013-05-24 18:56:32 EDT
The original problem is that restart failed. The URL listed in the error message is the one that the REST API call was made (in this case, it is the app restart URL). The thing is, doing a GET on the URL will not work and result in a routing error since you cannot list events, rather only create events like start/stop/restart etc.

With this context, maybe we need to rethink about listing the URLs in our error messages so as not to lead users to believe that they can simply do a GET on the URL to check if its available.
Comment 4 Lili Nader 2013-05-24 20:52:50 EDT
This error message is generated by the client tools.  Perhaps a better message to give in case of a NotFound/404 response from the broker is to ask the user to run "rhc domain show" or "rhc app show.  To verify if their app exists and contains the cartridges.
Comment 5 Clayton Coleman 2013-06-05 22:12:52 EDT
We only display this error if the server returns 404 and HTML.  If the broker returns JSON we display the error message and not the message Sumana saw.

It's unlikely this is a client error.
Comment 6 Lili Nader 2013-07-25 18:15:11 EDT
I think this should be fixed with changes in this pull request submitted by clayton.

https://github.com/openshift/origin-server/pull/3078
Comment 7 zhaozhanqi 2013-07-26 02:26:42 EDT
verified this bug on devenv_3653
when the server no response, the URL change to 'https://<instance>/broker/rest/api'


steps:

  1) create one app
  2) stop service rhc-broker
  3) restart the app

  after step 3: we will get the result:
[zqzhao@dhcp-13-222 non_scalable]$ rhc app restart sspring
The server did not respond correctly. This may be an issue with the server configuration or with your connection to the server (such as a Web proxy or firewall). Please verify that your proxy server is working correctly
(http://file.rdu.redhat.com:3128/) and that you can access the OpenShift server https://ec2-54-224-110-134.compute-1.amazonaws.com/broker/rest/api

Note You need to log in before you can comment on or make changes to this bug.