Bug 962985 - SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on the directory root.anchor.1113-0.
SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on th...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: unbound (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
abrt_hash:c26f346edcc276b7dc1e5f794d2...
:
: 963067 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 17:35 EDT by Moez Roy
Modified: 2013-06-22 00:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-22 00:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-14 17:35:39 EDT
Description of problem:
SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on the directory root.anchor.1113-0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that unbound-anchor should be allowed add_name access on the root.anchor.1113-0 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep unbound-anchor /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:named_t:s0
Target Context                system_u:object_r:named_conf_t:s0
Target Objects                root.anchor.1113-0 [ dir ]
Source                        unbound-anchor
Source Path                   /usr/sbin/unbound-anchor
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           unbound-libs-1.4.19-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-94.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.11-200.fc18.x86_64 #1 SMP Wed
                              May 1 19:44:27 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-05-13 17:55:27 PDT
Last Seen                     2013-05-14 14:32:53 PDT
Local ID                      77cc3c49-dd11-45cf-9668-d3faab331cf0

Raw Audit Messages
type=AVC msg=audit(1368567173.980:268): avc:  denied  { add_name } for  pid=1113 comm="unbound-anchor" name="root.anchor.1113-0" scontext=system_u:system_r:named_t:s0 tcontext=system_u:object_r:named_conf_t:s0 tclass=dir


type=SYSCALL msg=audit(1368567173.980:268): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff10299a20 a1=241 a2=1b6 a3=238 items=0 ppid=1 pid=1113 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=unbound-anchor exe=/usr/sbin/unbound-anchor subj=system_u:system_r:named_t:s0 key=(null)

Hash: unbound-anchor,named_t,named_conf_t,dir,add_name

audit2allow

#============= named_t ==============
allow named_t named_conf_t:dir add_name;

audit2allow -R
require {
	type named_t;
}

#============= named_t ==============
bind_manage_config_dirs(named_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.8.11-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-15 05:03:39 EDT
AFAIK we fixed it in F19 with using of /var/lib/unbound.
Comment 2 Miroslav Grepl 2013-05-15 05:04:22 EDT
*** Bug 963067 has been marked as a duplicate of this bug. ***
Comment 3 Tomáš Hozza 2013-06-03 08:54:30 EDT
This sounds like unbound problem rather than bind. Moving to unbound.
Comment 4 Paul Wouters 2013-06-03 14:22:08 EDT
This should be fixed in the latest version of unbound and selinux-policies.

Can you try and update and see if you still see these?
Comment 5 Moez Roy 2013-06-03 21:01:48 EDT
(In reply to Paul Wouters from comment #4)
> This should be fixed in the latest version of unbound and selinux-policies.
> 
> Can you try and update and see if you still see these?

Yes it is fixed with below:

unbound-libs-1.4.20-3.fc18.x86_64
unbound-1.4.20-3.fc18.x86_64

Note You need to log in before you can comment on or make changes to this bug.