Bug 963016 - Please drop the gettext dep
Please drop the gettext dep
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 21:40 EDT by Matthias Clasen
Modified: 2013-05-14 23:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 22:09:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2013-05-14 21:40:45 EDT
It is documented as 'needed for the libvirt-guests initscript'.

However, that initscript doesn't exist anymore, and the systemd service file shows no signs of needing gettext.
Comment 1 Eric Blake 2013-05-14 22:09:30 EDT
The systemd service file calls into the /usr/libexec/libvirt-guests.sh shell script, and THAT file DOES deppend on gettext.  Basically, when we moved from initscripts to systemd, we migrated what used to be the init script into a standalone shell script that both initscripts and systemd could reuse.

As such, I'm closing this as not a bug; the dependency on gettext is intentional.
Comment 2 Eric Blake 2013-05-14 23:09:14 EDT
That said, I did make this upstream tweak to fix the comment.

commit 9615ca59c6ec41fc2f41b2b89087ff1cacfd1dec
Author: Eric Blake <eblake@redhat.com>
Date:   Tue May 14 20:14:34 2013 -0600

    spec: fix outdated comment
    
    https://bugzilla.redhat.com/show_bug.cgi?id=963016 points out that
    we don't use initscripts by default on Fedora any more.
    
    * libvirt.spec.in (Requires): Better explanation of gettext.
    
    Signed-off-by: Eric Blake <eblake@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.