Bug 963025 - [rfe] split up the base package
[rfe] split up the base package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnustep-base (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 22:11 EDT by Rahul Sundaram
Modified: 2013-05-31 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: gnustep-base-1.24.4-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 23:13:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2013-05-14 22:11:08 EDT
Description of problem:

I introduced unar into the Fedora repo which is a program that uses gnustep.  However the Fedora desktop live image had to drop the unar dependency on file-roller because gnustep is too big

https://admin.fedoraproject.org/updates/FEDORA-2013-7885/file-roller-3.8.1-4.fc19

Would you be willing to split up the package further and I can see if we can squeeze it back in? For comparison, debian has the following split

http://anonscm.debian.org/gitweb/?p=pkg-gnustep/gnustep-base.git;a=blob;f=debian/control;h=9e66852c354d07062bd7203bc7113ff668bf966f;hb=HEAD

unar only needs the runtime support
Comment 1 Fedora Update System 2013-05-16 12:34:44 EDT
gnustep-base-1.24.4-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnustep-base-1.24.4-7.fc19
Comment 2 Fedora Update System 2013-05-17 18:17:12 EDT
Package gnustep-base-1.24.4-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnustep-base-1.24.4-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8423/gnustep-base-1.24.4-7.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-05-31 23:13:07 EDT
gnustep-base-1.24.4-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.