Bug 963052 - "Import Manifest" UI element interferes with dropdown menus.
"Import Manifest" UI element interferes with dropdown menus.
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-05-14 23:57 EDT by Corey Welton
Modified: 2013-07-18 17:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-18 17:19:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot (64.40 KB, image/png)
2013-05-15 00:00 EDT, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2013-05-14 23:57:49 EDT
Description of problem:
When the "Import Manifest" UI arrow is on the screen and user tries to use a main level menu dropdown that would normally overlay it, the "arrow" portion remains on screen and if user tries to mouseover to a submenu, it interferes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Content > Subscriptions > Red Hat Subscriptions
2. Noting the +Import Manifest UI element, hover atop the 'Content' menu and note that the arrow for Import manifest does not 'hide' behind the menu as expected.
3.  Attempt to scroll directly atop the arrow, over to the submenu that would appear to the right of the offending arrow. Note that the exact menu might vary based on your font size configuration but on my screen it is Content > Repositories > Red Hat Repositories
Actual results:
Arrow displays through menu, steals focus, forces menu closed.

Expected results:
Arrow should stay hidden, should not steal focus.

Additional info:
Comment 1 Corey Welton 2013-05-15 00:00:35 EDT
Created attachment 748051 [details]
Comment 2 Brad Buckingham 2013-05-29 11:10:58 EDT
This appears to have been resolved in both upstream master and downstream satellite build; therefore, moving this one to ON_QA for verification.
Comment 3 Og Maciel 2013-05-29 18:01:26 EDT
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-cert-consumer-qeblade35.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-41.noarch
* foreman-postgresql-1.1.10002-41.noarch
* katello-1.4.2-7.el6sat.noarch
* katello-all-1.4.2-7.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-7.el6sat.noarch
* katello-configure-1.4.3-10.el6sat.noarch
* katello-configure-foreman-1.4.3-10.el6sat.noarch
* katello-foreman-all-1.4.2-7.el6sat.noarch
* katello-glue-candlepin-1.4.2-7.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
* katello-glue-pulp-1.4.2-7.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.12-1.el6sat.noarch
* signo-katello-0.0.12-1.el6sat.noarch
Comment 4 Mike McCune 2013-07-18 17:19:52 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.