Bug 963098 - Left/Right cursor key does not work in the initial conversion state
Summary: Left/Right cursor key does not work in the initial conversion state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libkkc
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F19Beta-accepted, F19BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-15 06:55 UTC by Daiki Ueno
Modified: 2013-05-24 20:16 UTC (History)
3 users (show)

Fixed In Version: ibus-kkc-1.5.13-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-24 20:16:14 UTC


Attachments (Terms of Use)

Description Daiki Ueno 2013-05-15 06:55:51 UTC
Description of problem:
Left/Right cursor key no longer works in the initial conversion state.

Version-Release number of selected component (if applicable):
libkkc-0.2.2-1.fc19

How reproducible:
always

Steps to Reproduce:
1. type "a a a" and commit preedit with RET
2. move cursor with Left/Right
3.
  
Actual results:
cursor does not move

Expected results:
cursor should move left and right

Additional info:
This is a regression after bug 958718 and should be fixed with the latest upstream release 0.2.3.

Comment 1 Fedora Update System 2013-05-15 12:55:07 UTC
ibus-kkc-1.5.13-1.fc19,libkkc-0.2.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-kkc-1.5.13-1.fc19,libkkc-0.2.3-1.fc19

Comment 2 Fedora Update System 2013-05-15 16:45:43 UTC
Package ibus-kkc-1.5.13-1.fc19, libkkc-0.2.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-kkc-1.5.13-1.fc19 libkkc-0.2.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8272/ibus-kkc-1.5.13-1.fc19,libkkc-0.2.3-1.fc19
then log in and leave karma (feedback).

Comment 3 Daiki Ueno 2013-05-17 06:36:33 UTC
Proposing as a BetaFreezeException, since this behavior is quite annoying for typical Japanese users.

Comment 4 Adam Williamson 2013-05-20 18:10:28 UTC
Discussed at 2013-05-20 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-20/f19beta-blocker-review-7.2013-05-20-16.07.log.txt . Accepted as a freeze exception issue: this affects use of KKC on the live images, it's kind of a pain to use with this bug. I have tested that 0.2.3 works okay and fixes this bug, plus the change is obviously limited to the KKC input method itself and can't  break anything else, so it's pretty safe.

Comment 5 Fedora Update System 2013-05-24 20:16:14 UTC
ibus-kkc-1.5.13-1.fc19, libkkc-0.2.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.