Bug 963123 - perl-ExtUtils-Typemaps-Default-1.03 is available
perl-ExtUtils-Typemaps-Default-1.03 is available
Status: CLOSED DUPLICATE of bug 977266
Product: Fedora
Classification: Fedora
Component: perl-ExtUtils-Typemaps-Default (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 03:51 EDT by Upstream Release Monitoring
Modified: 2013-06-24 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 07:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-05-15 03:51:24 EDT
Latest upstream release: 1.03
Current version in Fedora Rawhide: 1.01
URL: http://search.cpan.org/dist/ExtUtils-Typemaps-Default/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Miro Hrončok 2013-06-13 07:20:35 EDT
Latest upstream release 1.03 requires ExtUtils::Typemaps >= 3.18_03

> ExtUtils::Typemaps (3.16) is installed, but we need version >= 3.18_03

ExtUtils::Typemaps is provided by binary package perl-ExtUtils-ParseXS, which is built from perl source package.

Marcela, should I file a bug against perl to include ExtUtils::Typemaps >= 3.18_03, or close this one? Thanks
Comment 2 Petr Pisar 2013-06-13 07:42:19 EDT
root@fedora-20:~ # repoquery --whatprovides 'perl(ExtUtils::Typemaps)'
perl-ExtUtils-ParseXS-1:3.18-1.fc20.noarch
root@fedora-20:~ # repoquery --whatprovides 'perl(ExtUtils::Typemaps)' --source
perl-ExtUtils-ParseXS-3.18-1.fc20.src.rpm
root@fedora-20:~ # perl -MExtUtils::Typemaps -le 'print $ExtUtils::Typemaps::VERSION'
3.18

ExtUtils::Typemaps is provided by standalone perl-ExtUtils-ParseXS and the version is 3.18. This is the latest available _stable_ version from CPAN <http://search.cpan.org/~smueller/ExtUtils-ParseXS/>. The 3.18_3 is experimental one.

I recommend to wait for 3.19 release.
Comment 3 Miro Hrončok 2013-06-13 08:04:12 EDT
I don't quite get it, I see:

%package ExtUtils-ParseXS
...
Epoch:          1
Version:        3.16

In perl.spec.

But I'll wait for 3.19 release, thanks.
Comment 4 Miro Hrončok 2013-06-24 07:54:41 EDT

*** This bug has been marked as a duplicate of bug 977266 ***

Note You need to log in before you can comment on or make changes to this bug.