Bug 963130 - Some usernames are UTF-8 encoded twice
Some usernames are UTF-8 encoded twice
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Accounts (Show other bugs)
4.2
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Matt Tyson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 04:06 EDT by Zdeněk Pavlas
Modified: 2014-10-12 18:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.4.1013
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 20:13:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdeněk Pavlas 2013-05-15 04:06:24 EDT
Description of problem:

Some usernames are not displayed correctly, eg. mls@suse.de.  Instead of 'Michael Schröder' it's rendered as 'Michael Schröder'.

How reproducible:

Open https://bugzilla.redhat.com/show_bug.cgi?id=905209

Additional info:

u'öd'.encode('iso-8859-1') == '\xc3\xb6'
unicode('\xc3\xb6', 'utf-8') == u'ö'

There are probably more such cases.  Other accented usernames, eg mine, are displayed correctly.  It should be fairly easy to detect and fix the above cases in the user database.  (every username that's not ascii clean and could be sucessfully utf8-decoded twice is very likely mangled).  u'Zdeněk Pavlas' is correct, because ord(u'ě') > 255, and it can't be utf-8 decoded again.
Comment 4 Zdeněk Pavlas 2014-01-22 02:57:42 EST
Apparently, not fixed: https://bugzilla.redhat.com/show_bug.cgi?id=905209#c7
Comment 5 Simon Green 2014-01-22 07:01:44 EST
(In reply to Zdeněk Pavlas from comment #4)
> Apparently, not fixed: https://bugzilla.redhat.com/show_bug.cgi?id=905209#c7

It won't be fixed on the production server until the bug is marked CLOSED/CURRENTRELEASE. Before this however, it needs to be tested on the development and staging servers.

  -- simon
Comment 7 Jason McDonald 2014-02-03 20:13:41 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.